Closed Bug 15665 Opened 21 years ago Closed 20 years ago

Can't highlight text in a link

Categories

(Core :: DOM: Selection, defect, P3, minor)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: netdragon, Assigned: mjudge)

Details

(Whiteboard: [nsbeta3+])

[4.Xp]8/24/99 12:00 Build

You cannot highlight the text in the middle of a link.
Summary: Gecko Closes → Highlighting
Assignee: don → mjudge
QA Contact: leger → elig
Summary: Highlighting → Can't highlight text within a link
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WONTFIX
I'm not sure if I understand the bug report correct; e.g. you can't select part
of the text of a link in 5.x, but you could in 4.x?

If so, I'm resolving this as WONTFIX for mjudge --- neither IE or Navigator
support this functionality, and implementing it in a fashion that wouldn't
confuse users is, in my opinion, non-trivial.

If you mean to submit an enhancement request_ for this, or if you meant to submit
it as something different, please re-open it with your comments.
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
I meant to say that in Mozilla, you can't highlight a link by clicking on the
link, holding down and dragging. This was in Netscape Communicator.
Resolution: WONTFIX → ---
Really? What version? I'm not able to make that happen in 4.7 for Mac OS or
Windows.

If you hold on a link and drag, it should (on 4.7) invoke a drag-and-drop
behavior, rather than a selection.
Assignee: mjudge → pinkerton
Status: REOPENED → NEW
Mike,

This is probably a duplicate of "Drag & Drop not yet implemented", but I thought
I'd pass it along for you.

Specifically, the issue raised is the Windows-specific behavior in which a user
holds down the mouse button for 1-2 seconds on a link --- and when the link is
highlighted as draggable, it can be copied onto the clipboard.
Assignee: pinkerton → mjudge
this isn't my department. the client (in this case, gecko) needs to determine
what to do with the DragGesture event it gets. i only implement _mechanism_, not
_policy_. bumping back to you.
OS: Windows 98 → All
Hardware: PC → All
I can reproduce this selection behavior on Windows NT 4.6.   Click the left
mouse button down on a URL and drag a few pixels to the left or right on the URL
.  The whole URL text will become selected.   This would be nice to have in
Mozilla too.
Component: Browser-General → Selection
Target Milestone: M14
I think this can wait until after beta 1; set to M14; change component back to
Selection.

Michael--should the summary be changed to say "Can't highlight text of a link"
rather than "Can't highlight text within a link"?
Summary: Can't highlight text within a link → Can't highlight text of a link
[I'm not Mike, but yes. ;-]
I agree that is a better name.
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
setting to M15 (post beta bucket), setting status to assigned
The way to allow selection of link text is with the Shift key. If Shift is held 
down, clicking, dragging etc should behave exactly as they would if the link was 
not there.

This behavior has the following advantages:
* 4xp on MacOS (though not on Windows);
* consistent with the only other software I know of which has an analagous
  feature (selecting buttons in the MacOS Finder's View as Buttons mode);
* more flexible than the Windows 4.x behavior of only allowing the text of a
  whole link to be selected.

Gotchas to be aware of when implementing this:
* If a selection already exists when the link is Shift+clicked, extend the
  selection -- just as you would if the link wasn't there.
* When the mouse pointer is over a link, toggle between a pointy hand pointer and
  an I-beam pointer depending on whether Shift is down, so as to give the correct
  indication of what a click would do at that moment.

Changing summary back.
Keywords: 4xp
Summary: Can't highlight text of a link → Can't highlight text in a link
Sounds good to me. Three more gotchas:
-Like all other key combinations, the help file should list them all. On some 
combinations, they can be placed in the Edit menu but shift drag can't.
-The highlight link can by dragging can be placed in menu bar i.e.
Highlight Link   Click+Drag
-CTRL+C or copy should copy the text after you have dragged on a link to 
highlight all text

hmm m16ing this one. I am not sure if this is a selection issue since the 
problem lays in the fact that the frame is never told about the mouse down when 
over a link. I will probably bounce this one to the style guys. I will make sure 
i have some person acknowlege this before I just send it off though dont worry
Target Milestone: M15 → M16
In linux with 4.x you can select text in links with midlemousebutton, this also
doesn't work on mozilla.
moving out to M17
Target Milestone: M16 → M17
per beppe
Keywords: 4xpcorrectness, nsbeta3
Target Milestone: M17 → M18
setting to nsbeta3+
Whiteboard: nsbeta3+
adding brackets to status whiteboard
Whiteboard: nsbeta3+ → [nsbeta3+]
fixed.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
*SPAM*: Changing the QA contact of all open/resolved Selection bugs from 
elig@netscape.com to BlakeR1234@aol.com.  After the many great years of service 
Eli has given to Mozilla, it's time for him to move on; he has accepted a 
position at Eazel.  We'll be sad to see him go, and I'll do my best to fill his 
spot...
QA Contact: elig → BlakeR1234
The text of links does select upon dragging for me, but could the reporter 
please verify that this wis what was originally reported?  I'm a bit confused 
by Matthew's comments re: how to select text within links when modifiers are 
pressed, and how Brian seemed to agree with what Matt was saying (which was 
nothing about selecting the contents of links upon dragging, as far as I could 
tell).
Reopening. In build 2000082608 on Mac OS 9.0, if you drag a link to nowhere, the 
whole text of the link is selected. I think that's a bug: if you select some text 
and then aim at a JavaScript link which uses document.getSelection(), but 
accidentally hit another link instead, you should be able to drag the other link 
a short distance in order to avoid following it, without disturbing your original 
selection.

And the original bug has not been fixed: you can't highlight arbitrary text in 
the middle of a link. When you hold down Shift over a link, the cursor does not 
change to an I-beam; and Shift+dragging from within link text drags the link, 
instead of making a selection.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
If you click on a link, hold and drag, it should highlight the link. It should 
still start the drag drop if needed, but afterwards, the text in the link should 
be highlighted so someone can copy the text. I like the shift idea for 
highlighting only some of the text within a link, but there has to be a way of 
letting people know about this feature. 
Matthew, I couldn't fully understand what you said, but it sounded like a 
separate bug.  The original bug here was to have the text of a link select upon 
dragging, *not* the ability to select text within a link using modifier keys 
(despite the misleading original summary -- read the reporter's latest comment). 
 So that should be a separate bug also.  Tentatively marking fixed again.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
> The original bug here was to have the text of a link select upon dragging

In that case, I think it should have been wontfix, for the reason I gave in my 
last comment.

Since you insist, filed separate bug 50673, `Can't start a selection inside a 
link'.
Status: RESOLVED → VERIFIED
Keywords: correctness
I tried this out on build 2000110120 on WinNT4, but neither changes the pointer
to an I-beam over a link when pressing shift, nor can I select some text within
the link.

Can someone with more privileges than I have please reopen this bug? Thanks.
Stephan, what you're asking for is bug 50673.
You need to log in before you can comment on or make changes to this bug.