Closed Bug 1566505 Opened 2 years ago Closed 2 years ago

Update panel content when messages change

Categories

(Firefox :: Messaging System, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: andreio, Assigned: andreio)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

Right now we populate the What's New panel once and then reuse the same content if it is opened again (both from the toolbar and the application menu).
If we happen to publish a new message in RS that will not show up until browser restart.

P3 since we don't have any messages now.

Priority: -- → P3

Is this still a p3?

Flags: needinfo?(andrei.br92)

I still think it's unlikely that the content will change during a browser session and we need to update the view for the user, but it's not a big change to make.
Just to confirm the scenario where this would happen is:

  • Users starts the browser
  • Opens the What's New panel (at this point messages are cached)
  • RS pulls new messages (that were not available when the browser started otherwise the user would have seen these)
  • User opens What's New panel again during the same browser session
Flags: needinfo?(andrei.br92)
Summary: Update panel content when messages changes → Update panel content when messages change
Assignee: nobody → andrei.br92
Iteration: --- → 71.3 - Sept 30 - Oct 13
Priority: P3 → P1
Blocks: 1586093
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9098863 [details]
Bug 1566505 - Update panel content when messages change

Beta/Release Uplift Approval Request

  • User impact if declined: There's a small risk of showing users older messages in the What's New section
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch, tested in Nightly
  • String changes made/needed:
Attachment #9098863 - Flags: approval-mozilla-beta?

Do we need this for sure in 70? Can you get a verification in nightly? It seems like a fairly edge case scenario to me. But, if you feel strongly about it going into 70 let me know.

Flags: needinfo?(tspurway)
Flags: needinfo?(edilee)
Flags: needinfo?(andrei.br92)

QA steps:

  1. open what's new panel (e.g., from app menu)
  2. see generic tracking protection message and/or "back up your passwords" lockwise message
  3. visit pages until about:protections shows 100+ blocked and/or sign in to fxa

actual:
see the same messages from step 2

expect:
tracking protection should show 100+ "trackers blocked" message and/or "take your passwords with you" lockwise message

Flags: needinfo?(mcoman)
Flags: needinfo?(cmuresan)
Flags: needinfo?(acupsa)

@Ed, thanks for the provided steps.
I have verified this issue using the steps provided in comment 9 on Latest Firefox Nightly 71.0a1 (Build ID: 20191008214557) on Windows 10 x64, Mac 10.14.6 and Arch Linux.

  • The "Trackers blocked" message is displayed replacing the "Protect yourself from trackers" after visiting several pages and having over 100 trackers blocked (shown in the about:protections page)
  • The "Take your passwords with you" message is displayed replacing the "Back up your passwords" message after logging into FxA.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mcoman)
Flags: needinfo?(cmuresan)
Flags: needinfo?(acupsa)

I think this bug is likely to reproduce because we have a lot of messaging pushing users to log in to Firefox Accounts (which I think is the most likely path). Now that it has also been verified I think we should uplift.

Flags: needinfo?(tspurway)
Flags: needinfo?(edilee)
Flags: needinfo?(andrei.br92)

Comment on attachment 9098863 [details]
Bug 1566505 - Update panel content when messages change

Skyline support, verified in nightly, OK for beta 14 uplift.

Attachment #9098863 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

There is a conflict, please update the patch.

Flags: needinfo?(andrei.br92)

I've resolved the test conflicts for https://phabricator.services.mozilla.com/D48193

Flags: needinfo?(andrei.br92)
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I have verified this issue with the steps provided in Comment 9 on Latest Firefox Beta 70.0b14 (Build ID: 20191010142853) on Windows 10 x64, Mac 10.14.6 and Arch Linux 4.16.6 x64.

  • The "Trackers blocked" message is displayed replacing the "Protect yourself from trackers" after visiting several pages and having over 100 trackers blocked (shown in the about:protections page)
  • The "Take your passwords with you" message is displayed replacing the "Back up your passwords" message after logging into FxA.
Attachment #9098863 - Attachment is obsolete: true
Attachment #9098863 - Attachment is obsolete: false
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
QA Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.