Closed Bug 1567183 Opened 2 years ago Closed 2 years ago

Hyphenation dictionary for German

Categories

(Core :: Layout: Text and Fonts, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1557291

People

(Reporter: esnempusae, Unassigned)

Details

Attachments

(1 file)

Attached file hyphentest.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

OS: Win 10.
Firefox: 68.0 (64-Bit)

I used German hyphenation library lang="de" for hyphens: auto.
Almost no words got hyphenated.
The library name in documentation:
"Hyphenation dictionary for German, Reformed Orthography of 1996 (de, de-1996, de-DE, de-AT, de-*)"

The library does work in Firefox version 67.

When researching, I found that lang="de-1901" (an older German hyphenation dictationary according to the documentation) is working.
"Hyphenation dictionary for German, Traditional Orthography of 1901 (de-1901, de-AT-1901, de-DE-1901)"

I attached an HTML example displaying both cases; it is a reduced w3cschool example.

The Swiss hyphenation library seems to be similarly affected.
"Hyphenation dictionary for German, Swiss Orthography (de-CH, de-CH-*)"

Actual results:

German words do not get hyphenated correctly.

Expected results:

German words should get hyphenated.

I assume it's the same as bug 1566542 (duped against bug 1557291). It only happens on uppercase words, and it's been fixed in 69.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1557291

(In reply to Francesco Lodolo [:flod] from comment #1)

I assume it's the same as bug 1566542 (duped against bug 1557291). It only happens on uppercase words, and it's been fixed in 69.

Right, that's what we're seeing here.

As a workaround, you can add a boolean pref intl.hyphenate-capitalized.de = true in about:config.

Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.