Downloaded files have wrong extensions

VERIFIED DUPLICATE of bug 120327

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 120327
16 years ago
13 years ago

People

(Reporter: Hans Schleichert, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On many occasions, downloaded files are given the .PDF extension. This happens
always when I try to download nightly mozilla builds, but also when I'm trying
to open an Excel (.XLS) Email attachment. The attachment is clearly not PDF (nor
is the nightly mozilla build):

Content-Type: application/octet-stream; name="BETEIL~1.XLS"
Content-Transfer-Encoding: base64
Content-Disposition: inline; filename="BETEIL~1.XLS"
Content-MD5: t/SZY5LFqNtF6J4gfVsn/g==

Mozilla then tries to launch the Acrobat reader rather than my Excel viewer,
which of course creates garbage on screen. I haven't seen this in releases prior
to 1.1alpha. Is there a place where mozilla stores what it believes to be a
likely file type fpr the next download, or something like that?

Comment 1

16 years ago
Reporter,

Can you look into Edit->Preferences->navigator->Helper Applications. You
probably have Acrobat set to handle application/octet-stream. If this is teh cae
then this bug is a dupe of bug 120327
IS a dupe of bug 120327, Content-Type: application/octet-stream is the give-away

Comment 3

16 years ago
marking as such. reporter: please reopen if you disagree.

*** This bug has been marked as a duplicate of 120327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.