Closed Bug 1567493 Opened 1 year ago Closed 8 months ago

Date Input field pushes the year back by one year each time you type a “0” in the month part of the input field

Categories

(Core :: DOM: Core & HTML, defect, P3)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: el.charafeddine, Assigned: smaug)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot_1.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

In a date input field:
1-Click to show calendar
2-Type in the month (08 for instance). I typed in 0 then 8.

Actual results:

The calendar is pointing at 2018 instead of current year 2019.

Expected results:

Calendar should still be pointing at 2019, or any year previously set in the year part of the input field.

This behavior

Summary: Date Input field shows incorrect year on user typing zero in month part while calendar open → Date Input field pushes the year back by one year each time you type a “0” in the month part of the input field

This behavior doesn't happen on FF v66

Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

uum, I can also reproduce the issue on Firefox66.0.5 Windows10.

Regression Window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d7b0d0e7228da9d690df6f105b865db973789c34&tochange=945baa8bc9603cd870bf0f9806b437506765fe15

Regressed by: 342633799d0850f79cf27db8c826cdc4149a2cd9 Olli Pettay — Bug 1445207, populate input type=date's .value when changing the value in the UI, r=mconley

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
Regressed by: 1445207
Component: Layout: Form Controls → DOM: Core & HTML

We dropped down to using a free form input text instead of "date" cause that issue is confusing our users(we received complains about it). How long that is it take in average for these kinda bugs to be fixed and deployed ?

Thanks :)

Priority: -- → P3

Happy to take a patch for 70 but since this is triaged and set to P3 priority I'm setting it as fix-optional.
That will remove the bug from weekly regression triage.

Tweaking the patch for bug 1445207 a tiny bit.
Unfortunately we don't seem to have good way to test this.

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b2bf4da40350
Date Input field pushes the year back by one year each time you type a '0' in the month part of the input field, r=mconley
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+

This issue is verified as fixed in our latest Release build Fx 72.0.2 on Windows 10, Mac OsX 10.13 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.