Mozilla crashes when clicking on links in page info panel

RESOLVED DUPLICATE of bug 154692

Status

--
critical
RESOLVED DUPLICATE of bug 154692
17 years ago
13 years ago

People

(Reporter: fredbezies, Assigned: db48x)

Tracking

({crash})

Trunk
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020710
BuildID:    2002071008

See steps.

Reproducible: Always
Steps to Reproduce:
1.go to http://www.ms.uky.edu/~mai/java/stat/buff.html 
2.right click / page info
3.click on links

Actual Results:  mozilla die without crashing

Expected Results:  showing links

Using WinXP - JRE 1.4.0.

See this bug on netscape.public.mozilla.general and post it.

Comment 1

17 years ago
WFM build 0000000000 redhat 7.3 2.4.18

Comment 2

17 years ago
confirming using build 2002071008 on Linux (trunk) + JRE 1.4.1 beta: TB8198735W.
Keywords: crash, stackwanted
OS: Windows XP → All
Hardware: PC → All
Summary: Mozilla closes itself when clicking on links in page info panel → Mozilla crashes when clicking on links in page info panel
Whiteboard: Need TB8198735W data

Comment 3

17 years ago
Boris, should I ask you for TB8198735W?
Confirming with build 2002070904 WinXP. Talback ID : TB229319H
TB8198735W:

s_GetProperty()
js_Interpret()
js_Invoke()
nsXPCWrappedJSClass::CallMethod()
nsXPCWrappedJS::CallMethod()
PrepareAndDispatch()
nsXPTCStubBase::Stub3()
nsTreeWalker::TestNode()
nsTreeWalker::ChildOf()
nsTreeWalker::FirstChildOf()
nsTreeWalker::ChildOf()
nsTreeWalker::FirstChildOf()
nsTreeWalker::ChildOf()
nsTreeWalker::FirstChildOf()
nsTreeWalker::ChildOf()
nsTreeWalker::FirstChildOf()
nsTreeWalker::NextInDocumentOrderOf()
nsTreeWalker::NextNode()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
PresShell::HandleDOMEventWithTarget()
nsButtonBoxFrame::MouseClicked()
nsButtonBoxFrame::HandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEventWithTarget()
nsEventStateManager::CheckForAndDispatchClick()
nsEventStateManager::PostHandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsViewManager::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::DispatchMouseEvent()
nsWidget::OnButtonReleaseSignal()
nsWindow::OnButtonReleaseSignal()
nsWindow::HandleGDKEvent()
dispatch_superwin_event()
handle_gdk_event() 

TB229319H:

no stack

Comment 6

17 years ago
Isn't siggnature js_GetProperty()? IMHO this is dupe of bug 154692... 
BTW my crash 2002070913/trunk/W2K -> TB8233922X
Keywords: stackwanted
Whiteboard: Need TB8198735W data

*** This bug has been marked as a duplicate of 154692 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.