Closed Bug 1567930 Opened 1 year ago Closed 1 year ago

Normandy NextGen Study add-ons are enrolled in the "NO_BRANCHES" branch

Categories

(Firefox :: Normandy Client, defect)

69 Branch
Desktop
All
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox69 --- affected
firefox70 --- affected

People

(Reporter: ppop, Unassigned)

References

Details

Attachments

(1 file)

Attached image no_branches.gif

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Affected Versions]:

  • Firefox Nightly 70.0a1, Build ID 20190721215935

[Prerequisites]:

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to about:telemetry and click the "Events" button.
  3. Scroll down and search for the study's "enroll" ping.
  4. Observe the "extra" section of the enroll ping.

[Expected result]:

  • The "branch": <branch_name> attribute is displayed.

[Actual result]:

  • The "branch": "NO_BRANCHES" attribute in displayed.

[Notes]:

  • The "1563805450087 app.normandy.action.AddonStudyAction DEBUG Enrolling in branch NO_BRANCHES" string is displayed in the browser console.
  • I have attached a screen recording of the issue:

Michael could you take a look at this please?

Flags: needinfo?(mcooper)

This is expected behavior. opt-out-studies it the old add-on Normandy action for add-on studies. The new one is branched-addon-study. It isn't available just yet on stage to test. It is waiting to deploy today.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mcooper)
Resolution: --- → FIXED

The new action branched-addon-study is available on Delivery Console stage now.

Marking this as verified fixed since the branched-addon-study action has landed.

Status: RESOLVED → VERIFIED
Blocks: 1522214
You need to log in before you can comment on or make changes to this bug.