Hitting "Back" button crashes on imagemap

VERIFIED FIXED in M5

Status

Core Graveyard
Viewer App
P1
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Eli Goldberg, Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using the 11.23.98a builds of Viewer & XP Viewer (checked on Win98 & NT 4):

1. Go to www.apple.com
2. Select any of the destinations at the bottom of the page (I tried
"Support", "Design and Publishing", and "Developer"
3. Hit the "Back" button.

Upon reaching the http://www.apple.com/main/maps/navbar2.map "page", the viewer
goes down. (Talkback ID for crashing on "Design and Publishing" is KWV14ZVC)

*** Please note that this crash is only occuring on Win98; can't reproduce on NT
4. ***
(Reporter)

Comment 1

19 years ago
I take that back. Talkback ID KWU23JYH using XPViewer on NT 4. ;)

Updated

19 years ago
Assignee: rickg → kipp

Comment 2

19 years ago
This doesn't seem to crash anymore, but pressing the back button causes the
viewer to display a page claiming that imagemap coordinates were not sent.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: kipp → joki
Status: ASSIGNED → NEW
Summary: ss: Hitting "Back" button crashes on imagemap → Hitting "Back" button crashes on imagemap

Comment 3

19 years ago
Since there is no crash, I've removed the "stop-ship" tag.

I'm reassigning this one to you, tom, because it seems to be a double-event
dispatch. I've attached a simple test case (you will have to substitute in your
own images) that demonstrates the bug: because the image-map image is in an A
tag, we end up double link-triggering when we click on one of the map spots.

The result in the viewer is that we go to the A tag's location first and then we
go to the image maps location second. So for a momemnt the display looks right;
but as soon as you hit the back button the double trip is exposed.
(Reporter)

Comment 4

19 years ago
*** Bug 1584 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

19 years ago
[Using the 1.27.99 builds, Viewer will now take the user to the apple/macosx page
upon pressing the "Back" button, rather than returning the user to the
www.apple.com page.

Communicator 4.5 RTM, of course, returns the user directly to www.apple.com]

Comment 6

19 years ago
Setting all current Open Critical and Major to M3

Updated

19 years ago
Target Milestone: M3 → M5

Comment 7

19 years ago
Not a priority, as viewer is going away; but the underlying issue needs to be
fixed.
(Reporter)

Comment 8

19 years ago
[The 4.13.99 M4 candidate on Mac OS, Linux and Win32 (using Apprunner) do not
display any user-evident manifestation of this bug, should it still be present.

Specifically, one can press the "Back" button without crashing or any errors, in
the scenario described in the bug report.]
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Yeah, I've been putting this one off because it hasn't reproduced for me
either.  If no one else is seeing it either I'm marking it fixed.
(Reporter)

Comment 10

19 years ago
Thanks. (I'll check this more thoroughly today or on Monday, and then mark as
Verified if appropriate.)
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
Sure. Verifying as fixed. (Can't reproduce on the 4.16.99 optimized builds on
either Mac OS, Linux, or Win NT 4.0 SP3.)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.