Closed Bug 1568145 Opened 1 year ago Closed 1 year ago

langpack version varies between builds

Categories

(Firefox Build System :: General, defect)

68 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1565504

People

(Reporter: mozillabmw, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Build the openSUSE:Factory/MozillaFirefox package twice

Actual results:

All langpacks had one of their version fields differ as seen in
https://rb.zq1.de/compare.factory-20190713/MozillaFirefox-compare.out

Expected results:

It should be possible to get bit-identical results from multiple builds, even without mercurial metadata.
See https://reproducible-builds.org/ for why.

Please review/test/merge the attached patch
or come up with a better patch (e.g. use the MOZ_BUILD_DATE environment variable)

https://github.com/mozilla/gecko-dev/commit/8677f9f1f67ebad8ec439d9f4d25aa6767c307c2
says this was added for
Bug 1395459 - Store the version of the locale data in a langpack based on HG push timestamp.

Component: Untriaged → Internationalization
Product: Firefox → Core

That's the same as bug 1565504, right?

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Internationalization → General
Product: Core → Firefox Build System
Resolution: --- → DUPLICATE
Duplicate of bug: 1565504
You need to log in before you can comment on or make changes to this bug.