Closed Bug 1568231 Opened Last month Closed Last month

PushComponents.jsm initiates the PushService too eagerly

Categories

(Core :: DOM: Push Notifications, task)

task
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1369436

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxperf])

Here's a profile from the 2018 reference device where initting the PushService takes just under a second: https://perfht.ml/2YkL5H4

It might be worth delaying this a bit more, perhaps via the idle task queue here: https://searchfox.org/mozilla-central/rev/4436573fa3d5c4311822090e188504c10c916c6f/browser/components/BrowserGlue.jsm#1975

Bug 1369436 had a patch to try and make initialization lazy, but it broke push on Fennec, and I didn't have the cycles to figure out why. 😭

See Also: → 1369436
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → DUPLICATE
Duplicate of bug: 1369436
You need to log in before you can comment on or make changes to this bug.