Closed Bug 1568295 Opened 4 months ago Closed 3 months ago

Expose Disconnect social tracker list (social-track-digest256) in GV API

Categories

(GeckoView :: General, enhancement, P2)

All
Android
enhancement

Tracking

(firefox-esr68 wontfix, firefox68 wontfix, firefox69 wontfix, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: cpeterson, Assigned: droeh)

References

Details

(Whiteboard: [geckoview:fenix:m8])

Attachments

(1 file)

Fenix would like to expose a user setting to toggle the Disconnect social tracker list (social-track-digest256):
https://github.com/mozilla-mobile/fenix/issues/3571

Depends on: 1566961, 1559217

Actually we've split the GV dependency off of the main Social Tracking Protection work into a follow-up: https://github.com/mozilla-mobile/fenix/issues/4277

Social Tracking Protection will not be using the Disconnect social tracker list (social-track-digest256). It will be using this list, which is still being refined: https://github.com/mozilla-services/shavar-prod-lists/blob/master/social-tracking-protection-blacklist.json

(In reply to Chris Peterson [:cpeterson] from comment #0)

Fenix would like to expose a user setting to toggle the Disconnect social tracker list (social-track-digest256):
https://github.com/mozilla-mobile/fenix/issues/3571

Is that not this table that is exposed by GeckoView? https://searchfox.org/mozilla-central/rev/0bcdfa99339c0512e3730903835fb6f8ed45e3c4/mobile/android/geckoview/src/main/java/org/mozilla/geckoview/ContentBlocking.java#454

I think there is a disconnect here. You don't need social-track-digest256 for this feature, but instead you need social-tracking-protection-digest256.

I believe social-tracking-protection-digest256 maps to https://github.com/mozilla-services/shavar-prod-lists/blob/master/social-tracking-protection-blacklist.json. Needinfo baku to confirm.

Note that list is outdated today and being refined in this issue https://github.com/mozilla-services/shavar-list-creation-config/issues/52. That will probably be done sometime next week.

Flags: needinfo?(amarchesini)
Duplicate of this bug: 1568667
Assignee: nobody → droeh

It should be correct, but I'm not familiar with the shavar source code.

Flags: needinfo?(amarchesini)

(In reply to Tanvi Vyas[:tanvi] from comment #4)

I think there is a disconnect here. You don't need social-track-digest256 for this feature, but instead you need social-tracking-protection-digest256.

Ah indeed, thanks Tanvi!

Dylan, please also note that you also need to enable some prefs currently in order to get this to actually work right now. I filed bug 1569698 in order to simplify this. Hopefully that will be fixed in the next couple of days...

baku, can you clarify how social-tracking-protection-digest256 and child(?) lists like social-tracking-protection-facebook-digest256 relate to social-track-digest256? Are the former more or less strict than the latter? Is there a reason to keep exposing social-track-digest256 once we have STP support in GV?

Flags: needinfo?(amarchesini)

(In reply to :Ehsan Akhgari from comment #7)

(In reply to Tanvi Vyas[:tanvi] from comment #4)

I think there is a disconnect here. You don't need social-track-digest256 for this feature, but instead you need social-tracking-protection-digest256.

Ah indeed, thanks Tanvi!

Dylan, please also note that you also need to enable some prefs currently in order to get this to actually work right now. I filed bug 1569698 in order to simplify this. Hopefully that will be fixed in the next couple of days...

Thanks! I'll keep an eye on that bug.

(In reply to Dylan Roeh (:droeh) (he/him) from comment #8)

baku, can you clarify how social-tracking-protection-digest256 and child(?) lists like social-tracking-protection-facebook-digest256 relate to social-track-digest256? Are the former more or less strict than the latter? Is there a reason to keep exposing social-track-digest256 once we have STP support in GV?

Moving NI to Luke.

Flags: needinfo?(amarchesini) → needinfo?(lcrouch)

I believe social-track-digest256 is the "Social" category of the Disconnect list.

Priority: -- → P2
Whiteboard: [geckoview:fenix] → [geckoview:fenix:m8]

:ehsan is right - social-track-digest256 is the "Social" category of Disconnect.

All the social-tracking-protection-* lists are specific to STP, and the social-tracking-protection-digest256 is a combination of the -facebook and -twitter lists.

Flags: needinfo?(lcrouch)
Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/03c01af7e1c8
Add social tracking protection support to GV. r=geckoview-reviewers,snorp,agi
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

firefox69=wontfix because I assume we don't need to uplift the social tracking protection support to GV 69 Beta. It will ride the trains with GV 70 to Beta next week (September 2). Fenix can pick up GV 70 Beta then.

You need to log in before you can comment on or make changes to this bug.