Closed Bug 1568436 Opened 1 year ago Closed 1 year ago

Using the Mouse Wheel to open a Bookmark is switching to tab

Categories

(Firefox :: Bookmarks & History, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 469456

People

(Reporter: andro.marian.v94, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Click on a Bookmark with mouse Wheel.

Actual results:

The opened tab is focused immediately.

Expected results:

To not focus the tab if the option "When you open a link in a new tab, switch to it immediately" is disabled.

  • 2 hotkeys are reversed:

Website link:
* Normal click: Open the link is same page.
* Ctrl+Click: Open the link in new tab. Without Focus.
* Shift: Open the link in a new window.
* Ctrl+Shift: Open the link in new tab. With Focus.

Bookmark link:
* Normal click: Open the link is same page. (SAME)
* Ctrl+Click: Open the link in new tab. With Focus. (WRONG)
* Shift: Open Open the link in a new window. (SAME)
* Ctrl+Shift: Open the link in new tab. Without Focus. (WRONG)

Component: Untriaged → Bookmarks & History

check browser.tabs.loadBookmarksInBackground in about:config

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469456

Why is that by default false?

And why is not an option in Options page under tabs...

You need to log in before you can comment on or make changes to this bug.