Closed Bug 1568657 Opened 6 months ago Closed 6 months ago

WebDriver's PointerType should implement Copy and Clone

Categories

(Testing :: geckodriver, enhancement, P1)

67 Branch
enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: george.roman.99, Assigned: george.roman.99)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Since WebDriver's PointerType doesn't implement either Clone or Copy, it's cumbersome to pass it around and use within the code.

Expected results:

PointerType should implement the Clone and Copy traits.

Implement Clone for WebDriver's actions::PointerType

Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46c0127ab366
Change WebDriver PointerType to implement Clone r=ato
Assignee: nobody → george.roman.99
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.