Closed Bug 1568932 Opened 1 year ago Closed 11 months ago

Address settle-time regression from optimistic loading

Categories

(Firefox :: New Tab Page, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.2 - Jul 22 - Aug 4
Tracking Status
firefox69 + verified
firefox70 --- verified

People

(Reporter: gsuntop, Assigned: gsuntop)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(3 files)

No description provided.

Either roll back entirely or wait until after initial layout has settled to start optimistic preloading.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Blocks: perf-tweaks
Iteration: --- → 70.2 - Jul 22 - Aug 4
Priority: -- → P1

[Tracking Requested - why for this release]: Performance regression.

Blocks: 1570745
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Keywords: github-merged
Target Milestone: --- → Firefox 70

Comment on attachment 9084024 [details]
Uplift 1568932 - reverting PR #5111 due to perf regression (#5210)

Beta/Release Uplift Approval Request

  • User impact if declined: UX and revenue impact because of performance regression.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Load a new tab page.
  1. Set network in devtools to GPRS
  2. Scroll down until you start seeing more images loading.

Images should start loading as soon as 1 pixel comes into view.
Without this, images would start to load 200 pixels before the image comes into view. With GPRS set, you can scroll just before an image, and wait, then see if an image has started to load.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a revert to older functionality, and it's also really small.
  • String changes made/needed: none
Attachment #9084024 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I have verified this issue with the latest Firefox Nightly (70.0a1 Build ID - 20190808214929) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, an image starts to load only after it comes into view.

Status: RESOLVED → VERIFIED

Comment on attachment 9084024 [details]
Uplift 1568932 - reverting PR #5111 due to perf regression (#5210)

Reverts us back to older behavior to fix a perf regression on the New Tab Page. Approved for 69.0b13.

Attachment #9084024 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified this issue with the latest Firefox Beta (69.0b13 Build ID - 20190812173625) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, an image starts to load only after it comes into view.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.