can't pick many addresses to send to

RESOLVED DUPLICATE of bug 160339

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 160339
16 years ago
13 years ago

People

(Reporter: Wenqing Jiang, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020710
BuildID:    20020710

I used the mozilla browser to login mail.yahoo.com
and send mail.  I pick about 20 recipients from
address book dialog box.  After clicking OK the
dialog box didn't close, and the addresses didn't
go to the "To:" text field.

If I pick one or two addresses, everything is good.
IE doesn't have this problem when I pick 20.

I guess this is related to JavaScript problem?

Reproducible: Always
Steps to Reproduce:
1.the process is described in the "description" box.
2.Sorry I can't give you may mail account password
  for you to try out.
3.But you can set up a testing account and put two
  dozens of entries in address book and they try to
  send a mail to all of them by picking them from
  the address book (not by typing addresses directly
  into the "to:" field.
(Assignee)

Comment 1

16 years ago
Do you see errors in the JS Console ?
Tools\Web Development\Javascript Console..
(Reporter)

Comment 2

16 years ago
I made a mistake in saying I can pick one or two recipiens OK.  That's not
right.  I can pick one or two before in an earlier build (didn't try up
to 20 before).

The tools->web development->java script console reads:
Error: xw has no properties
Source File:
http://popup.msn.com/popupad.asp?PG=HOTPOP&msid=000115774C2E5042&SC=PP&COUNTRY=CA&UC=1
Line: 6
Error: uncaught exception: Permission denied to get property
HTMLFormElement.elements
That may not correspond to the error I encountered during sending mail.
(Assignee)

Comment 3

16 years ago
Do you block something in edit\preferences\advanced\Scripts ?
(Reporter)

Comment 4

16 years ago
No.  Enable JavaScript for Navigator, but not Mail&Newsgroups (I'm using web mail)
the first 3 items of "Allow scripts to:" have be unchecked.  Other items left
checked.

That's it.
(Assignee)

Comment 5

16 years ago
Please try it again and enable all scripts in 
"Allow scripts to:" field.
(Reporter)

Comment 6

16 years ago
I have tried.  No use.  (I didn't restart the browser.  Should I?)

Comment 7

16 years ago
*** Bug 160043 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Confirming based on the report in the duplicate bug 160043
by baffoni@aerovironment.com:

---
When I use my Yahoo mail account, the address book function doesn't copy
addresses into the to: list.

To reproduce:
1) log into yahoo mail
2) compose an email
3) click on the TO: button
4) put a check mark in one of your addresses (create one if you don't have one)
5) click done

What should happen: the window should hide, bring the email window forward and
populate the to: field with the selected address.

What actually happens: the address window clears, nothing else happens, no
address is filled into the window.  

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020716

Works correctly with Netscape 4.79, and correctly in Netscape 7.0PR1.
---
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
Michael: do you see the same error as indicated in Comment #2 above?
 
     (Go to Tools > Web Development > Javascript Console;
      be sure to clear it of any previous errors first!)


I'm wondering if this is all due to a corrupted profile.  Wenqing,
Michael: could you try launching Mozilla from a console like this:

     [(path to Mozilla)] ./mozilla -profilemanager

to make the Profile Manager come up (if it doesn't automatically...)
Once it comes up, choose "Create New Profile" and see if that helps.

I'm hoping that when you run Mozilla under a brand-new profile,
the problem will go away -
(Reporter)

Comment 10

16 years ago
new profile tried.  problem persists.

Comment 11

16 years ago
Wenqing: thanks! If you go to 

           Tools > Web Development > Javascript Console
    
and clear it of any previous errors first, are you getting any
errors from yahoo.com?
(Reporter)

Comment 12

16 years ago
But there isn't any error there.

Comment 13

16 years ago
This is a duplicate of bug 160339,
"Yahoo! Mail inserting addresses from address book no longer works in 1.1b"

I'm going to resolve this as a duplicate, since bug 160339 has more
information in it about the JavaScript at the Yahoo mail site. I will
cc everyone here on the other bug so you can follow the progress on it -

*** This bug has been marked as a duplicate of 160339 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.