Closed Bug 1569467 Opened 2 years ago Closed 2 years ago

Footer of protection panel is cut on localized build

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: flod, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(3 files)

Attached image immagine.png

I assume it happens because the initial message spans on two lines.

Interestingly enough, if you click the "Site not working?" link, and go back, the footer is fully displayed.

No longer blocks: protections-panel
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567296
Duplicate of bug: 1564077

This bug was duped against bug 1564077, but I'm still seeing the issue on 70.0a1 (2019-08-02) after the other bug was fixed.

The build is based on a changeset that includes that fix
https://hg.mozilla.org/mozilla-central/rev/5ced3811411e9b6f8f1ba02f518d0a5966a412af

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached image immagine.png

Updated image with localized footer (landed in the past 24h).

Summary: Footer of identity panel is cut on localized build → Footer of protection panel is cut on localized build

Yup, this one isn't on Andrew, though :)

Assignee: nobody → jhofmann
Status: REOPENED → ASSIGNED
Priority: -- → P1
Whiteboard: [privacy-panel][skyline]

We were hiding these labels by setting the "hidden" attribute by default and then, in CSS,
negating the effect of "hidden" by using display: unset;. Turns out this isn't a great
idea because doing this won't remove the "hidden" attribute, which some code relies on
to figure out whether the element is hidden. Like in this case PanelMultiview:
https://searchfox.org/mozilla-central/rev/0ffa9e372df56c95547fed9c3433ddec4fbf6f11/browser/components/customizableui/PanelMultiView.jsm#1402

Here it tries to find elements to process as part of descriptionHeightWorkaround,
and that skips this technically visible element because it still has the hidden attribute.

Luckily that's easy to fix.

Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e332c09026d
Avoid setting the "hidden" attribute on protections popup switch labels. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Regressions: 1571680
Flags: qe-verify+

Hello!
Reproduced the issue with Firefox 70.0a1 (20190728214940) it-build on Windows 10x64.
The issue is verified with 70.0a1 (20190728214940) on Windows 10x64. Tracking protection panel is correctly displayed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.