Closed Bug 1569568 Opened 2 years ago Closed 6 months ago

Add option to generate a new secure password from the context menu for the same principal and session

Categories

(Toolkit :: Password Manager, enhancement, P3)

70 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1551723
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- wontfix
firefox71 --- wontfix

People

(Reporter: aflorinescu, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [passwords:generation])

Reusing the "Use a securely generated password" to generate a second secure password is not possible for the same session/principal: the generated secure password is cached and reused throughout the session for the same principal.

Possible workarounds to do the above would be private window(unavailable due bug 1566533) , containers or just old plain browser restart: none of these options are straight-forward or intuitive for an user.

We already had bug 1551723 filed but it was specific to autocomplete so I made this be for the context menu. This is in our AC MVP++ list already for things to consider adding to the MVP list so I will remove it from Skyline.

Priority: -- → P3
See Also: → 1551723
Summary: Add option to generate a new secure password for the same principal and session → Add option to generate a new secure password from the context menu for the same principal and session
Whiteboard: [passwords:generation] [skyline] → [passwords:generation]
Blocks: 1571647
Flags: qe-verify+
Depends on: 1595915
Duplicate of this bug: 1621599
Duplicate of this bug: 1630500
Duplicate of this bug: 1633125
Duplicate of this bug: 1652486
Duplicate of this bug: 1668216
Duplicate of this bug: 1674668
Duplicate of this bug: 1679079
Duplicate of this bug: 1694595

Since there are heuristics available to collect password+usernames from login forms, can we not use the same heuristics to determine if the same username fields are set in the form doing this password generation?
If then we collect the username from the field, we could use that to supplement the salt for the password generator, and create new password-generator principal/session based on the user supplied username.

The context menu now opens the autocomplete menu, so I'm going dupe this to bug 1551723

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551723
You need to log in before you can comment on or make changes to this bug.