All users were logged out of Bugzilla on October 13th, 2018

Download manager slow when deleting multiple entries from list

VERIFIED DUPLICATE of bug 132331

Status

VERIFIED DUPLICATE of bug 132331
17 years ago
14 years ago

People

(Reporter: mozilla, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When deleting several/lots of entries from the listing of the download manager,
it takes very long.

Reproducible: Always
Steps to Reproduce:
1. Open Tools->Download Manager
2. Select several entries
3. Wait fairly long before Mozilla can be used again

Actual Results:  Here (Dual PPro 200) Mozilla is completely blocked for ~30s
when deleting 50 entries. During that time the file downloads.rdf seems to be
rewritten for every deleted entry.

Expected Results:  Mozilla should either do the deleting in one thread to not
block other surfing during that time, or do everything in memory and only write
the  file downloads.rdf once.
*** This bug has been marked as a duplicate of 132331 ***

*** This bug has been marked as a duplicate of 132331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.