embedding: need API to iterate over all editors in a session

NEW
Unassigned

Status

()

17 years ago
9 years ago

People

(Reporter: Brade, Unassigned)

Tracking

(Blocks: 2 bugs, {topembed+})

Trunk
topembed+
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In order for editor embedding to be complete, we need to complete this task:
 * There needs to be a way to iterate over all the editors in an nsIEditingSession
(Reporter)

Updated

17 years ago
Blocks: 157128

Comment 1

16 years ago
dup

*** This bug has been marked as a duplicate of 157105 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
reopening bug

Bug 157105 is for a specific api ("makeEditable") to be recursive.

This bug is for a generic mechanism for embedders to iterate over all of the
editors in an nsIEditingSession.  Embedders might want to do this for a save or
other output task (for example) or to apply a setting or such.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Keywords: topembed+

Updated

16 years ago
Target Milestone: --- → mozilla1.4alpha

Comment 3

16 years ago
marking 1.5 to revisit what we need for these embedding APIs
Status: REOPENED → ASSIGNED
Target Milestone: mozilla1.4alpha → mozilla1.5alpha
(Reporter)

Updated

16 years ago
Blocks: 14156

Comment 4

16 years ago
unsetting target milestone
Target Milestone: mozilla1.5alpha → ---
QA Contact: sujay → editor
Assignee: mjudge → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.