Closed Bug 1571444 Opened 4 months ago Closed 4 months ago

No message is displayed in the Login list if the search returns 0 results

Categories

(Firefox :: about:logins, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: cosmin.muntean, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline] [strings])

Attachments

(3 files)

Attached image search results 0.gif

[Affected Versions]:

  • Nightly 70.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have a Firefox profile with multiple saved logins.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Perform a search that returns 0 results.
  4. Observe the login list.

[Expected results]:

  • A "No matching logins" message is displayed.

[Actual results]:

  • No message is displayed, the list is blank.

[Notes]:

  • Attached a screen recording with the issue.
Blocks: 1572049

Ryan, should we show the "No logins found" text but without the "When you save…" paragraph?

Type: enhancement → defect
Flags: needinfo?(rgaddis)
Priority: -- → P2

Screenshot attached... I think it should look quite a bit like that, but have a slightly updated subtitle for no results found. Screenshot attached.

Zeplin: https://zpl.io/aRGlyj0

Flags: needinfo?(rgaddis)

It's also worth mentioning that we should consider closing out of the previously-selected login detail if it no longer matches the search query, no? (based on the screencap above, it seems weird to have facebook still active)

Whiteboard: [passwords:management] [skyline] → [passwords:management] [skyline] [strings]

Moving to P1 because strings (and because the resulting UX without it is not great) to make this block launch, with Product and UX blessing.

Priority: P2 → P1
Assignee: nobody → jaws
Status: NEW → ASSIGNED

The attached patch doesn't address comment #4 yet. Should we interrupt the filter to ask the user if they want to discard their changes? Should we also select the first login in the list as the user types?

Flags: needinfo?(rgaddis)

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #7)

The attached patch doesn't address comment #4 yet. Should we interrupt the filter to ask the user if they want to discard their changes? Should we also select the first login in the list as the user types?

Actually this is all tracked in bug 1575561 so I think we should leave it out of this patch.

Flags: needinfo?(rgaddis)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7004b8779a36
Show a message in the sidebar when the search returns 0 results. r=MattN,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue on the latest Nightly 70.0a1 (2019-08-29) (64-bit) on Windows 7 c64, MacOS 10.14 and Ubuntu 18.04.

  • The "No logins found | There are no results matching your search. " message is displayed on the Login List if the search returns 0 results.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Keywords: regression
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
You need to log in before you can comment on or make changes to this bug.