Closed Bug 1571529 Opened 1 year ago Closed 1 year ago

--enable-fission does not actually enable Fission

Categories

(Testing :: General, defect)

Version 3
defect
Not set

Tracking

(Fission Milestone:M4)

RESOLVED DUPLICATE of bug 1567264
Fission Milestone M4

People

(Reporter: kmag, Assigned: ahal)

References

(Blocks 2 open bugs)

Details

This led me down some prolonged and confusing wild goose chases. Apparently mach mochitest --enable-fission sets the fission mozinfo flag used by the test manifests, but does not actually enable Fission, leading to tests with fail-if annotations failing because they pass when expected to fail, and the leaks and crashes that I expect them to generate not happening. --setpref fission.autostart=true still does the right thing.

(Side-note: My guess is that this is because --enable-fission adds fission.autostart=1 rather than =true)

Oh, my mistake sorry about that.. I thought '1' was the correct value. Since bug 1567264 is leave-open I'm just going to fix in there.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567264
Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.