Memory leak with page having many images and meta refresh

RESOLVED WORKSFORME

Status

()

Core
Layout
P5
major
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: WD, Assigned: Marc Attinasi)

Tracking

({memory-leak, regression})

Trunk
Future
memory-leak, regression
Points:
---
Bug Flags:
blocking1.3b -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
*** 
NOTE:  URL for this bug will contain nudity!
***

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020710
BuildID:    2002071008

This website has many images on it than change frequently.   It has a meta
refresh to pick up the changes.   When mozilla is left on this page, the memory
usage rises continually.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.camwhores.com/index.php?group=3&num=999 (don't try it at
work, or you'll have some explaining to do....)
2.Leave browser open for a day or more
3.

Actual Results:  Mozilla's memory usage rises until the system is nearly unusable.
(I've seen it exeed 350MB)

Expected Results:  Mozilla's memory usage should plateau at some reasonable point.
-> Layout for triage
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: asa → petersen

Updated

16 years ago
QA Contact: petersen → amar

Updated

16 years ago
Priority: -- → P5

Updated

16 years ago
Target Milestone: --- → Future
(Reporter)

Comment 2

16 years ago
Created attachment 96610 [details]
BloatLog of page open for about 30 mins.

Not sure how to interpret it, but I made a bloat log of the page in question...
(Reporter)

Updated

16 years ago
Keywords: mlk

Comment 3

16 years ago
I have the same problem under somewhat different circumstances. MY Moz 1.1 got
to 432Megs (on NT4sp6) before I killed it. This was after 6 hours of use. I had
one frame open that refreshes (using javascript) every 15 seconds. The page is
basically text in a table with some links. There are some images, but most of
them are 'pixel.gif' (a single transparent pixel) which is then stretched to the
required size. 

Closing the window which contains this refreshing window does not release the
memory. 

This problem was not present in Moz 1.0. [I upgraded to 1.1 yesterday and
immediately started to see the problem].

Updated

16 years ago
Keywords: regression

Updated

15 years ago
Flags: blocking1.3b?

Comment 4

15 years ago
For the sake of information flow: there has been a checkin for bug 179498 that
fixes my observation of memory 'leakage' when loading images.

After updating to Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a)
Gecko/20021214, I can no longer see memory being leaked when loading images.

Since memory was lost everytime the an image loaded (even using reload), this
might have been the cause of this bug as well.

@reporter: coud you recheck whether or not this is still visible with e.g.
today's nightly?
Not serious.
Flags: blocking1.3b? → blocking1.3b-
Is this still a problem?
(Reporter)

Comment 7

15 years ago
The page in question has changed design slightly, so it's not possible to try
the original steps to reproduce of "Leave open for a day or more".   (After a
certain amount of time, the user is redirected to a non-refreshing page asking
to subscribe)

Anyway, with some brief testing, I can't seem to see any kind of memory leak
here.  During the reloads, memory usage fluctuates a little, but in the long run
it pretty much stays level.

This is with 2003042708 on Win2k.
(Reporter)

Comment 8

15 years ago
I don't believe this is still an issue.

-> WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.