Closed Bug 1572149 Opened Last month Closed Last month

Properly fix |Bug 943732 - Port the new Character Encoding menu to SeaMonkey|

Categories

(SeaMonkey :: MailNews: Composition, defect)

defect
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 943732 removed SetDocumentCharacterSet from MsgComposeCommands.js but it is still used by the function GenericSendMessage (https://searchfox.org/comm-central/source/suite/mailnews/components/compose/content/MsgComposeCommands.js#1796)

[Approval Request Comment]
Regression caused by (bug #): 943732
User impact if declined: Potential issues with setting correct character set when sending messages when original character set doesn't match new character set
Testing completed (on m-c, etc.):
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9083729 - Flags: review?(frgrahl)
Attachment #9083729 - Flags: approval-comm-release?
Attachment #9083729 - Flags: approval-comm-esr60?
Blocks: 1572152

Fix missing ) sorry

Attachment #9083729 - Attachment is obsolete: true
Attachment #9083729 - Flags: review?(frgrahl)
Attachment #9083729 - Flags: approval-comm-release?
Attachment #9083729 - Flags: approval-comm-esr60?
Attachment #9084188 - Flags: review?(frgrahl)
Attachment #9084188 - Flags: approval-comm-release?
Attachment #9084188 - Flags: approval-comm-esr60?

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/7f59fa9ad31a
Add missing SetDocumentCharacterSet() back to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Comment on attachment 9084188 [details] [diff] [review]
Bring back SetDocumentCharacterSet v1.1

[Triage Comment]
r/a=me
Attachment #9084188 - Flags: review?(frgrahl)
Attachment #9084188 - Flags: review+
Attachment #9084188 - Flags: approval-comm-release?
Attachment #9084188 - Flags: approval-comm-release+
Attachment #9084188 - Flags: approval-comm-esr60?
Attachment #9084188 - Flags: approval-comm-esr60+
Attachment #9084188 - Flags: approval-comm-esr52+
Attachment #9084188 - Flags: approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.