Closed Bug 1572439 Opened 4 months ago Closed 3 months ago

[Synced Tabs Sidebar] Firefox Nightly Fresh Profile cuts off icons from Synced Tabs sidebar

Categories

(Firefox :: Sync, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: amedinac, Assigned: eoger)

References

(Regression)

Details

Attachments

(3 files)

On a Firefox Nightly fresh profile

Steps to reproduce:

  1. Create Fresh Profile
  2. Show Sidebar
  3. Synced Tabs

This happens for both when the user has no account set up, and when the user has an unverified account.

Results in:

The Synced Tabs sidebar cuts of the icons. To see the full icon you'd have to expand the sidebar manually. I've added screen shots in the attachments section

The priority flag is not set for this bug.
:markh, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(markh)
Priority: -- → P2
Flags: needinfo?(markh)
Regressed by: 1568487
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Attachment #9090052 - Attachment description: Bug 1572439 - Remove the Synced Tabs sidebar min width. → Bug 1572439 - Don't import browser.css in Synced Tabs sidebar.
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4208c79a4e71
Don't import browser.css in Synced Tabs sidebar. r=dao
Duplicate of this bug: 1572754

We're gonna have to uplift this to 70.

Flags: needinfo?(eoger)
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9090052 [details]
Bug 1572439 - Don't import browser.css in Synced Tabs sidebar.

Beta/Release Uplift Approval Request

  • User impact if declined: The Synced Tabs sidebar will look broken for the user. See attachment 9084011 [details].
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple CSS change.
  • String changes made/needed:
Flags: needinfo?(eoger)
Attachment #9090052 - Flags: approval-mozilla-beta?

Comment on attachment 9090052 [details]
Bug 1572439 - Don't import browser.css in Synced Tabs sidebar.

CSS change, makes sense to move this out of browser.css.
OK for uplift for beta 5.

Attachment #9090052 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I verified this fix on Mac OS X 10.14 Nightly 71.0a1(2019-09-08) and I can confirm the fix. I will wait to verify also on Beta 70 b5.

I also verified this on Mac OS X 10.14 with FF Beta 70.0b5 and I can confirm the fix.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.