Closed Bug 1572493 Opened 1 year ago Closed 1 year ago

The legend icons in the protection report are misplaced in RTL mode

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: ehsan, Assigned: mtigley)

References

Details

(Keywords: rtl, Whiteboard: [protection-report][skyline])

Attachments

(3 files)

Attached image Screenshot

Please see the screenshot.

The icons need to be to the right of the number labels.

(In reply to :Ehsan Akhgari from comment #0)

Created attachment 9084082 [details]
Screenshot

Please see the screenshot.

The icons need to be to the right of the number labels.

What do you mean by number labels? As in, it should be "Protection level set to standard *(icon)"

Attached image Screenshot 2

(In reply to Erica Wright [:ewright] from comment #1)

(In reply to :Ehsan Akhgari from comment #0)

Created attachment 9084082 [details]
Screenshot

Please see the screenshot.

The icons need to be to the right of the number labels.

What do you mean by number labels?

My apologies, I attached the wrong screenshot. I meant the labels that you click on to switch panes in this screenshot.

As in, it should be "Protection level set to standard *(icon)"

Actually I didn't notice that problem in the screenshot I did attach. :-) So I guess we have two bugs here.

Whiteboard: [protection-report][skyline]
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5198dc0ba7b2
[RTL] Fix positioning of icons in the protection report graph. r=johannh
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+
QA Contact: ciprian.georgiu

I’ve reproduced this issue with Fx 70.0a1 (2019-08-08) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-10-14) and Fx 70.0b14 across platforms (Windows 10 x64, macOS 10.14, Ubuntu 18.04 x64).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.