Open Bug 1572687 Opened 1 year ago Updated 8 days ago

Disable the GFX sanity window because for some users it never closes

Categories

(Testing :: Marionette, defect, P3)

Version 3
defect

Tracking

(Not tracked)

People

(Reporter: whimboo, Unassigned)

References

(Blocks 2 open bugs, )

Details

Attachments

(2 obsolete files)

As discussed in bug 1420864 we want to disable the GFX sanity window of Firefox, which comes up for some users during startup, but never closes. As such Marionette doesn't initialize, and tests fail.

To cause the window even not to appear it should be enough to set the preference sanity-test.running to true.

https://searchfox.org/mozilla-central/rev/9775cca0a10a9b5c5f4e15c8f7b3eff5bf91bbd0/toolkit/components/gfx/SanityTest.jsm#347-350

I had to push another try build given that a unit test was failing on Windows where the gfx sanity window is active, and resets the newly added pref. Means that we have to skip testing this particular pref in the test.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=c557764149e9c0b44077ef1c92ae0c4d8e52112c

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b3e775a99cb
[marionette] Disable the GFX sanity window. r=webdriver-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/0c1fa26f2f67
[geckodriver] Disable the GFX sanity window. r=webdriver-reviewers,maja_zf
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

As it looks like this patch seem to have caused a start-up performance regression as covered on bug 1574837.

Sheriffs, can you please backout?

Flags: needinfo?(sheriffs)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla70 → ---
Attachment #9084265 - Attachment is obsolete: true
Attachment #9084266 - Attachment is obsolete: true

As proposed on bug 1574837, and agreed by Matt, the preference to be added to the GFX code can be sanity-test.disabled. It will be false by default.

Status: REOPENED → ASSIGNED

The priority flag is not set for this bug.
:automatedtester, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dburns)
Flags: needinfo?(dburns)
Priority: -- → P3
No longer blocks: 1520585
No longer blocks: 1573798
Blocks: 1584911

I'm currently not working on this bug.

Assignee: hskupin → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.