Closed Bug 1573063 Opened 8 months ago Closed 8 months ago

should blue dot indicating no tracking protection be on the app menu toolbar button?

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: heycam, Assigned: timhuang)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Attached image screen shot

When I'm viewing a page that I've turned tracking protection off for, I see a blue dot on the app menu toolbar icon. Is that its intended location? When I mouse over it, the shield button to the left of the address gets a hover highlight, so I'm wondering if it should be over there.

Hi Tim, can you say what the intended location of the blue dot is?

Flags: needinfo?(tspurway)

needinfod the wrong Tim. :) (Although maybe both Tims know the answer!)

Flags: needinfo?(tspurway) → needinfo?(tihuang)

Hi Cameron,

This is not the intended location. The blue dot should be on the shield icon.

Flags: needinfo?(tihuang)

I will look into that to figure out what happens there.

Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Component: Messaging System → Site Identity and Permission Panels
Priority: -- → P1
Whiteboard: [privacy-panel][skyline]

This bug is regressed by Bug 1569872 cuz it accidentally removed the 'position: relative;' from the tracking protection icon container. This rule is needed in order to correctly position the blue dot.

Regressed by: 1569872

The patch adds back the 'position: relative;' rule to the tracking
protection icon container. This is need in order to position the blue
dot.

Lol, this bug is really amusing, thanks for catching this!

(In reply to Tim Huang[:timhuang] from comment #5)

This bug is regressed by Bug 1569872 cuz it accidentally removed the 'position: relative;' from the tracking protection icon container. This rule is needed in order to correctly position the blue dot.

This wasn't accidental. I purposely removed position: relative because the border no longer needed it. But I forgot about the blue dot :)

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dbf1928cb18a
Fix the position issue of the blue dot indicator of the tracking protection icon. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+
QA Contact: ciprian.georgiu

I have reproduced this issue using Firefox 70.0a1 (2019.08.11) on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 70.0b14 on Win 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.