Closed Bug 1573248 Opened 2 years ago Closed 2 years ago

DiscoveryStream layout spocs_per_domain not followed

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox70 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

There is a server returned prop for spocs_per_domain which allows multiple spocs to be shown from the same domain.

There is a bug now which causes that to not be used, and it defaults to 1.

Assignee: nobody → sdowne
Priority: -- → P1
Iteration: --- → 70.4 - Aug 19 - Sep 1
Blocks: 1576284
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

To test:

  1. Set http://browser.newtabpage.activity-stream.asrouter.devtoolsenabled/ to true
  2. Go to about:home#devtools-ds
  3. Deselect hardcoded_layout
  4. Ensure show_spocs is set
  5. Under endpoint variant, toggle on staging_spocs
  6. Go to about:home
  7. Expected, see if any of the first few cards are sponsored by the same company.

This can produce false positives if the staging server happens to be returning all unique spocs at that moment. I'll see if I can find a better way to verify.

To verify a false positive, you can scroll down to the bottom of "about:home#devtools-ds" and look at what's in "Spoc data", if it matches what you're seeing, then the server simply returned no dupes for us to enable.

I have verified that this issue is no longer reproducible with the latest Firefox 69.0 rc2 (Build ID - 20190829214656) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the first three displayed cards are sponsored by the same company.
Thank you, Scott, for the steps from above :).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.