Closed Bug 1573592 Opened 2 years ago Closed 2 years ago

Update pageinfo gImageView.getCellProperties

Categories

(SeaMonkey :: Page Info, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file, 1 obsolete file)

Port parts of the following bugs:

  • Bug 377349 - Page info : Media Tab. The broken image indicator is often wrong
  • Bug 632119 - Fix View Image Info for Data URIs
  • Bug 792968 - Replace some regular expression string matches with String.startsWith and replace /^https?/ URI scheme tests with /^https?$/
Blocks: 1573595
Attached patch Update getcellproperties (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): Unknown
User impact if declined: The broken image indicator is often wrong
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch:None

Attachment #9085161 - Flags: review?(frgrahl)
Attachment #9085161 - Flags: approval-comm-release?
Attachment #9085161 - Flags: approval-comm-esr60?

Now including:

  • Bug 845055 - Check the mime type is not null before testing the mime type itself
Attachment #9085161 - Attachment is obsolete: true
Attachment #9085161 - Flags: review?(frgrahl)
Attachment #9085161 - Flags: approval-comm-release?
Attachment #9085161 - Flags: approval-comm-esr60?
Attachment #9085296 - Flags: review?(frgrahl)
Attachment #9085296 - Flags: approval-comm-release?
Attachment #9085296 - Flags: approval-comm-esr60?
Comment on attachment 9085296 [details] [diff] [review]
Update getcellproperties v1.1

lgtm r/a+
Attachment #9085296 - Flags: review?(frgrahl)
Attachment #9085296 - Flags: review+
Attachment #9085296 - Flags: approval-comm-release?
Attachment #9085296 - Flags: approval-comm-release+
Attachment #9085296 - Flags: approval-comm-esr60?
Attachment #9085296 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a561d6568206
Update pageinfo gImageView.getCellProperties. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.