Closed Bug 1573647 Opened 1 year ago Closed 3 months ago

Intermittent dom/tests/mochitest/general/test_windowedhistoryframes.html | State should be correct - got null, expected "STATE1"

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- wontfix
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: smaug)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered][stockwell unknown])

Attachments

(1 file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=261398964&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/Uo2xKEgTT1iXnWeCeyFqtw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-13T18:59:27.278Z] 18:59:27 INFO - 717 INFO TEST-PASS | dom/tests/mochitest/general/test_windowedhistoryframes.html | Page should be correct
[task 2019-08-13T18:59:27.278Z] 18:59:27 INFO - Buffered messages finished
[task 2019-08-13T18:59:27.278Z] 18:59:27 INFO - 718 INFO TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_windowedhistoryframes.html | State should be correct - got null, expected "STATE1"
[task 2019-08-13T18:59:27.278Z] 18:59:27 INFO - SimpleTest.is@SimpleTest/SimpleTest.js:320:16
[task 2019-08-13T18:59:27.278Z] 18:59:27 INFO - is@dom/tests/mochitest/general/historyframes.html:22:28
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - test_state_navigation@dom/tests/mochitest/general/historyframes.html:129:5
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - test_body@dom/tests/mochitest/general/historyframes.html:71:10
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - continueAsync/<@dom/tests/mochitest/general/historyframes.html:88:45
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - 719 INFO TEST-PASS | dom/tests/mochitest/general/test_windowedhistoryframes.html | URL should be correct
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - 720 INFO TEST-PASS | dom/tests/mochitest/general/test_windowedhistoryframes.html | Page should be correct
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - 721 INFO TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_windowedhistoryframes.html | State should be correct - got "STATE1", expected "STATE2"
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - SimpleTest.is@SimpleTest/SimpleTest.js:320:16
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - is@dom/tests/mochitest/general/historyframes.html:22:28
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - test_state_navigation@dom/tests/mochitest/general/historyframes.html:137:5
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - test_body@dom/tests/mochitest/general/historyframes.html:71:10
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - continueAsync/<@dom/tests/mochitest/general/historyframes.html:88:45
[task 2019-08-13T18:59:27.279Z] 18:59:27 INFO - 722 INFO TEST-PASS | dom/tests/mochitest/general/test_windowedhistoryframes.html | URL should be correct

Duplicate of this bug: 1573655

I'm quite sure that this was not caused by bug 1573577 but can't offer any further insight, sorry.

Flags: needinfo?(jhofmann)

(In reply to Johann Hofmann [:johannh] from comment #7)

I'm quite sure that this was not caused by bug 1573577 but can't offer any further insight, sorry.

Well at least we can exclude that theory. Thank you.

No longer regressed by: 1573577
Whiteboard: [retriggered]
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]
See Also: → 1575241, 1574032, 1582436, 1573892

I'll try to get to this on Friday

Olli did you get a chance to look?

Flags: needinfo?(bugs)
Flags: needinfo?(bugs)
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46948e618953
try to make test_windowedhistoryframes.html less racy by using popstate event and not timeout, r=peterv
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.