Closed Bug 1574025 Opened 2 years ago Closed 1 year ago

[WebExtensions] Allow to get and set the selected state of tabs

Categories

(WebExtensions :: Frontend, enhancement, P3)

69 Branch
enhancement

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: perso, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

It is possible to select several tabs in Firefox.

Actual results:

This state is not available in the WebExtensions API.

Expected results:

This state should be available to use and modify to extensions. This would be especially useful for vertical tabs extensions such as Tree Style Tab, or Tab Center Reborn which I’m developing.

Component: Untriaged → Frontend
Product: Firefox → WebExtensions
Version: 69 Branch → Firefox 69
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

So apparently tabs.highlight() is the API I want.

I edited several pages of MDN to tell developers that what the WebExtensions API means by «highlighting» is really not about emphasis and all about selection, so that people can’t misunderstand or not understand what tabs.highlight() and tabs.Tab.highlighted are about.

I guess you can close this bug as FIXED, since the root problem that led me to open this bug report, unclear documentation, has been fixed.

Version: Firefox 69 → 69 Branch
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.