Closed Bug 1574165 Opened 1 year ago Closed 1 year ago

Crash in [@ RecordReplayInterface_InternalRecordReplayAssert]

Categories

(Core Graveyard :: Web Replay, defect, P2)

Unspecified
macOS
defect

Tracking

(firefox70 affected)

RESOLVED DUPLICATE of bug 1573931
Tracking Status
firefox70 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-42598095-b8ef-46d8-83e1-89e2e0190814.

Seen while looking at nightly crash stats: https://bit.ly/2KCb3OB. 6 crashes/2 installs so far.

Some of the crashes have Moz Crash reason MOZ_RELEASE_ASSERT(mThread->CanAccessRecording())

Top 6 frames of crashing thread:

0 XUL RecordReplayInterface_InternalRecordReplayAssert toolkit/recordreplay/ProcessRecordReplay.cpp:320
1 XUL mozilla::recordreplay::RecordReplayAssert mfbt/RecordReplay.h:449
2 XUL js::gc::GCRuntime::startGC js/src/gc/GC.cpp:7871
3 XUL js::gc::GCRuntime::gcIfRequested js/src/gc/GC.cpp:8064
4 XUL JSContext::handleInterrupt js/src/vm/Runtime.cpp:510
5 XUL js::jit::CheckOverRecursed js/src/jit/VMFunctions.cpp:323

This crash report has a better stack: bp-d7b2558c-4e9e-4c22-9e22-9b6140190814

The priority flag is not set for this bug.
:bhackett, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(bhackett1024)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(bhackett1024)
Priority: -- → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 1573931
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.