Closed Bug 1574431 Opened Last month Closed 29 days ago

Preserve installTelemetryInfo when rebuilding the DB from the addons manifest

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: rpl, Assigned: rpl)

Details

Attachments

(1 file)

When XPIProvider DB_SCHEMA is changed (and also in response of changed to the lastModified timestamp for an xpi file) we update/rebuild the DB from the addons' manifests.

Currently the installTelemetryInfo is not being preserved in that cases (it is being overwritten with a null value when the DB is being rebuilt for a DB_SCHEMA change, and not copied from the old AddonInternal object into the new AddonInternal object when we update it for a particular addon because its xpi file lastModified timestamp has changed).

We should ensure that we preserve the installTelemetryInfo and add a test case to prevent it from regressing.

Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/b02a7e182628
Preserve installTelemetryInfo when rebuilding the DB from the addons manifest files. r=kmag
Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9085994 [details]
Bug 1574431 - Preserve installTelemetryInfo when rebuilding the DB from the addons manifest files.

Beta/Release Uplift Approval Request

  • User impact if declined: Abuse Reports submitted by the users may miss some useful details (related to how the addon has been installed) because the data (stored in the AddonManager's DB when the addon is installed) hasn't been preserved when the AddonManager's DB is rebuild (e.g. because of a DB schema change).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): - very small change (2-lines change, one avoids to overwrite the installTelemetryInfo property when rebuilding the DB because of a DB schema change, the other one ensure to copy the installTelemetryInfo from the old addon instance when rebuilding the DB because the xpi timestamp has been changed)
  • new tests included along with the fix.
  • String changes made/needed:
Attachment #9085994 - Flags: approval-mozilla-beta?
Flags: in-testsuite+

Comment on attachment 9085994 [details]
Bug 1574431 - Preserve installTelemetryInfo when rebuilding the DB from the addons manifest files.

Simple fix to avoid losing some important information for submitted addon abuse reports. Thanks for including new tests for this. Approved for 69.0rc1.

Attachment #9085994 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(lgreco)

Marking as qe-verify-, as it is explicitly tested as part of the automated tests.

Flags: needinfo?(lgreco) → qe-verify-

Comment on attachment 9085994 [details]
Bug 1574431 - Preserve installTelemetryInfo when rebuilding the DB from the addons manifest files.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This fix would prevent ESR68 from losing the installTelemetryInfo associated to the installed addons, otherwise (as also described in the Bug 1574431 comment 4 "User Impact" field) the "Abuse Reports submitted by the users may miss some useful details" (in particular the details related to how the addon has been installed).
  • User impact if declined: Same as Bug 1574431 comment 4
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Same as Bug 1574431 comment 4
  • String or UUID changes made by this patch:
Attachment #9085994 - Flags: approval-mozilla-esr68?

Comment on attachment 9085994 [details]
Bug 1574431 - Preserve installTelemetryInfo when rebuilding the DB from the addons manifest files.

Approved for 68.2esr.

Attachment #9085994 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
You need to log in before you can comment on or make changes to this bug.