Closed Bug 1574498 Opened 4 months ago Closed 3 months ago

The “Login List” is not scrolled to the top after sorting the logins

Categories

(Firefox :: about:logins, defect, P3)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified
firefox71 --- verified

People

(Reporter: simona.rosu, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

Attached video LoginList_sort.mp4

[Affected versions]:

  • Firefox latest Nightly 70.0a1 (2019-08-16) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 18.04 x64

[Prerequisites]:

  • The Firefox browser is opened.
  • The "about:logins" page is opened.
  • Have multiple saved logins.

[Steps to reproduce]:

  1. Scroll down the “Login List”.
  2. Click on the “Sort by: Name (A-Z)” dropdown menu.
  3. Select the “Last Used”/”Last Modified” option.
  4. Observe the behavior of the list.

[Expected result]:

  • The “Login List” is rearranged and is scrolled to the top.

[Actual result]:

  • The “Login List” is not scrolled to the top.

[Additional notes]:

  • Attached a screen recording with the issue.

Hi Ryan, where should the list scroll (if it should be) after getting sorted ?

Flags: needinfo?(rgaddis)
Status: NEW → UNCONFIRMED
Ever confirmed: false

I think it should function as Simona has described, and jump to the top of the login list, as long as we maintain the login you have selected as active regardless of changing the sort order.

For example... if I have my logins sorted alphabetically, and the first entry for Amazon is selected, once I change to sorting by recency, Amazon should still be selected in the main entry details area, though the Amazon list card may now be hidden (if it moves to the bottom of my login list due to not being recently used).

Flags: needinfo?(rgaddis)

It seems like Finder on macOS and Explorer on Windows keep the selected item scrolled into view after sorting, rather than scrolling to the top. Did you consider this as an option? It seems more natural to me.

Flags: needinfo?(rgaddis)
Priority: -- → P3

Fair point. I had (perhaps incorrectly) assumed that it would be more work to track and maintain visible presence of the item in the last, relative to the sort order changing, but also, and perhaps more importantly, that most folks will probably wish to change the sort order at the start of their experience, upon opening the management tab...

Since the first item is already selected by default, my concern was that the first item would 'drive' them to wherever it lands in the new sort order, rather than having the sort order appropriately prioritizing what is visible at the top of the list. Therefore, it felt to me like sort order should be a priority over active state visibility...

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(rgaddis)
Assignee: nobody → jaws
Status: NEW → ASSIGNED

This patch does not attempt to keep the selected login visible, as we select a login upon loading so the user may not care where their currently selected login resides within the sort order.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/708c110cf4ea
Scroll the login-list to the top after changing the sort order. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9093675 [details]
Bug 1574498 - Scroll the login-list to the top after changing the sort order. r?MattN

Polish issue for Skyline feature, part of batch uplift for beta 9.

Attachment #9093675 - Flags: approval-mozilla-beta+

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20190923094800) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04 x64.

  • The “Login List” is scrolled to the top after sorting the logins.

I have verified this issue on the Firefox Beta 70.0b9 (Build ID: 20190923154733) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04 x64.

  • The “Login List” is scrolled to the top after sorting the logins.
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: unspecified → 70 Branch
You need to log in before you can comment on or make changes to this bug.