Can not login to travelocity.

VERIFIED DUPLICATE of bug 7533

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 7533
19 years ago
18 years ago

People

(Reporter: Warren Harris, Assigned: rpotts (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The image buttons on the travelocity page listed above don't draw. They just
have the missing image icon.

(If the URL above doesn't work, you can get to the page by going to
http://www.Travelocity.com and clicking on the "Find/Book a Flight" button.)

Updated

19 years ago
Assignee: trudelle → warren

Comment 1

19 years ago
Those are just gifs, not XPToolkit buttons.  They are being loaded via https
though, which would seem to be your department. reassigning to you, if it isn't
in the transport, then this bug should probably go to gecko.
(Reporter)

Updated

19 years ago
Assignee: warren → dougt
(Reporter)

Comment 2

19 years ago
Looks like these button images are being fetched by https. Peter says he tried
this with cartman, but they still wouldn't load. Reassigning to dougt.

Updated

19 years ago
Depends on: 1646

Comment 3

19 years ago
This bug is block by 1646.  When the button is pressed, a javascript URL is
used.

Updated

19 years ago
Blocks: 13785

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: image buttons don't draw → Can not login to travelocity.

Comment 4

19 years ago
I now see the image buttons.  But when I click on the Create New Account
button, I get the follow message returned:

HTTP/1.0 403 Content wrong type.  The page continues and states, "your client
is not allow to access the requested object".

this works fine with 4.x

Comment 5

19 years ago
Created attachment 2404 [details]
Simpilified Login

Updated

19 years ago
Assignee: dougt → gagan
Status: ASSIGNED → NEW

Comment 6

19 years ago
This is an HTTP (not HTTPS) post problem:  It looks something like:


<FORM METHOD=POST
ACTION="http://dps1.travelocity.com:80/lognguest.ctl?SEQ=940893298611640"
NAME=guestEntry>
<INPUT TYPE=IMAGE
SRC="https://dps1.travelocity.com:443/v3graphics/tcy_lognguest.gif" WIDTH="176"
HEIGHT="38" BORDER="0" ALT="Be Our Guest">
<INPUT TYPE="HIDDEN" NAME="guest_flag" VALUE="Y">
<INPUT TYPE="HIDDEN" NAME="Service" VALUE="TRAVELOCITY">
<INPUT TYPE="HIDDEN" NAME="last_pgd_page" VALUE="lognlogin.pgd">
</FORM>

assigning to gagan.

Updated

19 years ago
Assignee: gagan → rpotts

Comment 7

19 years ago
rick gets this one...
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

19 years ago
It turns out that this is caused by mozilla sending 'charset=...' as part of the
Content-Type request header.  When the 'charset=...' is removed, the POST works
correctly.

Below is the request mozilla sent...

POST / HTTP/1.0
host: ruchi:4321
accept: */*
user-agent: Mozilla/5.0 [en-US] (Windows_NT; I)
referer: file:///s|/tmp/travelocity.html
Content-type: application/x-www-form-urlencoded; charset=ISO-8859-1
Content-Length:69

x=29&y=8&guest_flag=Y&Service=TRAVELOCITY&last_pgd_page=lognlogin.pgd


*** This bug has been marked as a duplicate of 7533 ***

Updated

18 years ago
No longer blocks: 13785

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
[bugday] verifying duplicate. charset bug.
You need to log in before you can comment on or make changes to this bug.