Gzipped SVG files (.svgz) don't work when loaded locally

VERIFIED DUPLICATE of bug 52282

Status

()

Core
SVG
--
enhancement
VERIFIED DUPLICATE of bug 52282
15 years ago
10 years ago

People

(Reporter: Alan, Assigned: jwatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Adobe illustrator 10 (only version i have to check with) exports SVGZ which is
simply an SVG file gzipped.  The Adobe SVG browser plugin displays these files.  

if you were to save an SVG file 'rectangle.svg' for example and save a copy of
it as SVGZ you would get *exactly* the same file contents in gzip archive called
rectangle.svgz, the archive would contain one file called 'rectangle' (no extension)
(Reporter)

Comment 1

15 years ago
link added severity changed to enhancement


Severity: normal → enhancement

Comment 2

15 years ago
SVGZ will work if the HTTP response header includes:

Content-Type: image/svg+xml
Content-Encoding: x-gzip

Thus this is an issue with server configuration, not Mozilla.

Comment 3

14 years ago
It would be nice if .svgz files could be viewed with Mozilla, in which case
there is no server for us to configure.

Also, .svgz files are supported by more SVG viewers than Adobe's plug-in alone.
 It may be expedient to special-case this format for the sake of people who have
checked their site on MSIE + AdoveSVGViewer and are suprised when Mozilla still
cannot display it.
(Assignee)

Comment 4

13 years ago
FIXED/INVALID? Files with extension .svgz on a server can be viewed when the
HTTP headers are set correctly, and opening .svgz files locally also works (try
viewing, and downloading and viewing the file linked to below). Mozilla does not
and will not decide how to handle remote files depending on file name extension
for security reasons. 

http://www.pinkjuice.com/svg/svgz/es.svgz
Summary: SVGZ Gzipped SVG (as seen in Adobe Illustrator 10) → Support SVGZ Gzipped SVG (as seen in Adobe Illustrator 10)
(Assignee)

Comment 5

13 years ago
Assigning to me so I remember to find out after doing mass reassign.
Assignee: alex → jonathan.watt
(Assignee)

Comment 6

13 years ago
Closing. One way to configure Apache to to send the correct headers for SVG
files it to add the following to a .htaccess file in a root directory. 

AddType image/svg+xml .svg
AddType image/svg+xml .svgz
AddEncoding x-gzip .svgz
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

13 years ago
Reopening. I would have sworn that Mozilla could view .svgz files loaded from
the hard drive, but apparently this has never worked. I think the times I tested
it previously, I first downloaded the .svgz files over HTTP and encountered bug
283272. Hence the .svgz files that I thought were compressed actually weren't.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Support SVGZ Gzipped SVG (as seen in Adobe Illustrator 10) → Gzipped SVG files (.svgz) don't work when loaded locally
(Assignee)

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 52282 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED

Comment 9

10 years ago
Not sure if fixing 52282 will support the following use case (So I will post this same comment in 52282 and in 157514:

A data:url containing svgz. The data url syntax doesn't have a way to specify that the content is gzip compressed, and there is only one MIME type for svg.
Mozilla throws up an XML parsing error. Opera handles it.

Why inline svgz in a data:url instead of using a compound XML document and compressing the whole thing?
1) Why not.
2) The whole XML / DTD doctype conunundrum to get the latter approach working.
3) I want to send the svg back to the server, and prefer to send compressed data.
You need to log in before you can comment on or make changes to this bug.