Closed Bug 1575144 Opened 5 months ago Closed 2 months ago

update Geolocation implementation to match latest spec

Categories

(Core :: DOM: Geolocation, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: anssi.kostiainen, Assigned: sidvishnoi, Mentored)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file, 6 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36

Steps to reproduce:

The Geolocation API specification renamed the following interfaces and removed the [NoInterfaceObject] annotation so that these types are now exposed to script:

Coordinates -> GeolocationCoordinates
Position -> GeolocationPosition
PositionError -> GeolocationPositionError

This is done in response to an effort to remove the [NoInterfaceObject] annotation from WebIDL.

Spec pull requests (merged):
https://github.com/w3c/geolocation-api/pull/20
https://github.com/w3c/geolocation-api/pull/23

Priority: -- → P3
Status: UNCONFIRMED → NEW
Ever confirmed: true

Hello,
I have set the component for this issue, but since i'm not sure if this is the right component please feel free to change it to one that suits it.

Component: Untriaged → General
Component: General → DOM: Geolocation
Product: Firefox → Core

The product::component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --

Marcos: are you able to assign this bug to yourself?

Flags: needinfo?(mcaceres)
Priority: -- → P3

Yep, I'll grab it... saving this for an intern who might be starting soon.

Flags: needinfo?(mcaceres)
Assignee: nobody → mcaceres
Assignee: mcaceres → sidvishnoi8
Mentor: mcaceres
Priority: P3 → P2
Summary: [geolocation] Rename interfaces and remove [NoInterfaceObject] → update Geolocation implementation to match latest spec

Depends on D51791

Depends on D51792

Depends on D51793

Depends on D51794

The Geolocation API specification renamed the following interfaces and removed the [NoInterfaceObject] annotation so that these types are now exposed to script:

  • Coordinates -> GeolocationCoordinates
  • Position -> GeolocationPosition
  • PositionError -> GeolocationPositionError

This is done in response to an effort to remove the [NoInterfaceObject]
annotation from WebIDL.

Additionally, the following interfaces are now only exposed in Secure Contexts:

  • GeolocationCoordinates
  • GeolocationPosition
Pushed by mcaceres@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aab5f870bf5e
Update Geolocation implementation to match latest spec r=baku,marcosc
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Keywords: dev-doc-needed
Attachment #9106485 - Attachment is obsolete: true
Attachment #9106484 - Attachment is obsolete: true
Attachment #9106483 - Attachment is obsolete: true
Attachment #9106482 - Attachment is obsolete: true
Attachment #9106481 - Attachment is obsolete: true
Attachment #9106486 - Attachment is obsolete: true

I've had a go at documenting this one on MDN; see https://github.com/mdn/sprints/issues/2461#issuecomment-564114752 for the full details.

Please let me know if I've missed anything; thanks!

Amazing work Chris! I didn't realize this many documents needed to be changed! Thank you for your work.

You need to log in before you can comment on or make changes to this bug.