Closed Bug 1575198 Opened 2 months ago Closed 2 months ago

Build browser with --enable-cranelift to keep on benchmarking Cranelift

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: bbouvier, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 1555894 has disabled the compilation of Cranelift in Firefox builds by default, unless --enable-cranelift is set in the configure line. This will probably break the AreWeFastYet performance testing of Cranelift, since the about:config pref is likely to be come useless.

The WebAssembly team still wants to measure performance of Cranelift on AWFY, though.

Would it be possible to set up a special build task, that would build the full Firefox browser with --enable-cranelift --enable-release at configure, and then set the pref javascript.options.wasm_cranelift to true? To make it cost-effective for Mozilla, having this task only run once per week would be enough; ideally this would be accompanied by a Perfherder run of the build on the two WebAssembly benchmark suites.

Joel, is this something that sounds feasible? Thanks!

Flags: needinfo?(jmaher)

having a build on nightly might be ok with the specific jobs running. On that frequency, who will look at the results? The perf sheriffs only look at integration branches. also if there is build breakage, who will fix it?

Flags: needinfo?(jmaher) → needinfo?(bbouvier)

Great, thanks!

If the results are sent to the main AWFY website, we (the WASM team) would take care of checking them; sheriffs shouldn't have to watch these.

Regarding build breakages: if there's a way for us to get notified when the build fails, that would be perfect! We'll then do the right thing according to the kind of build breakage (either fixing it ourselves or pinging the right people). If you need an email list for this, we can start with Lars (cc'd), Julian Seward (:jseward) and me.

Flags: needinfo?(bbouvier) → needinfo?(jmaher)

I see wasm-misc and godot as the two benchmarks we run for cranelift:
https://searchfox.org/mozilla-central/search?q=cranelift&path=taskcluster%2Fci

Are these the two?

:egao, could you look into standing up a build variant as outlined above (not a drop everything, but work it in this month if you can). This would be on the nightly scheduler.

Flags: needinfo?(jmaher) → needinfo?(egao)

I should be able to get this done before I go on parental leave 9/14.

Component: AWFY → General
Flags: needinfo?(egao)
Product: Testing → Firefox Build System
Version: Version 3 → unspecified
Component: General → Task Configuration

Thanks! (Just confirming Godot and wasm-misc are the two wasm benchmarks we're tracking.)

:glandium appears to be working on re-enabling cranelift in-tree, so advised me that I hold off for a bit.

While unclear if this is the correct approach, I did get to a point where I defined the tasks and it showed up in Treeherder, albeit not fully building:
https://hg.mozilla.org/try/rev/7fb80150dbe985cd24c9d94c4858f15da63b1079

With https://github.com/CraneStation/cranelift/pull/924, we should be able to re-enable cranelift at least on automation. That needs an update of cranelift in the tree first though.

Flags: needinfo?(bbouvier)

(In reply to Mike Hommey [:glandium] from comment #7)

With https://github.com/CraneStation/cranelift/pull/924, we should be able to re-enable cranelift at least on automation. That needs an update of cranelift in the tree first though.

Tracked in bug 1576591.

Flags: needinfo?(bbouvier)

Bug 1555894 disabled it for gecko builds, but since then bug 1576003
and https://github.com/CraneStation/cranelift/pull/924 landed, which
should make its cost to the build less problematic.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/14a789432117
Reenable cranelift on central. r=nalexander
Regressions: 1577046
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → mh+mozilla
You need to log in before you can comment on or make changes to this bug.