Closed Bug 1575220 Opened 4 months ago Closed 2 months ago

[Windows] Breach notifications are not displayed while High Contrast Mode is applied

Categories

(Firefox :: about:logins, defect, P1, minor)

70 Branch
All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- disabled
firefox68 --- disabled
firefox69 --- disabled
firefox70 + verified
firefox71 --- verified

People

(Reporter: ciprian_georgiu, Assigned: jaws)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [passwords:management] [skyline][access-p1])

Attachments

(4 files)

Affected versions

  • latest Nightly 70.0a1

Affected platforms

  • Windows 10 x64

Preconditions

  • have High Contrast mode applied on Windows
  • have at least one breached site saved in the profile-- instructions on how to do this can be found here

Steps to reproduce

  1. Access about:logins
  2. Inspect the breach warning icon and the "X" button from breach notification banner.

Expected result

  • The breach warning and the "X" button are correctly displayed.

Actual result

  • The breach warning and the "X" button are not displayed.

Regression range

  • Not a regression, I was able to reproduce it on older builds e.g. 70.0a1 (20190807215212) as well; one of the first builds with this feature implemented.

Additional notes

  • It seems that other banners that are having a "X" button are affected by this, so it could be a more general issue.
Has Regression Range: --- → no
Assignee: nobody → mcrawford
Status: NEW → ASSIGNED

ntim thought he heard that platform was going to fix images to show in HC mode so maybe we don't need to do anything specific to about:logins now?

Assignee: mcrawford → nobody
Status: ASSIGNED → NEW
Depends on: 1575689
Priority: -- → P3
Whiteboard: [passwords:management] [skyline] [depends on bug 1575689]
Has Regression Range: no → ---

The backplate feature will not be complete in time for this. I think removing the background images is the way to go.

OK. Since this is P3 I assume that doesn't have to be done in 70. (Though I would still take a patch in early beta.)

Bug 1576047 removed the background-image and replaced it with an <img>. This bug should be fixed once bug 1576047 is fixed.

Depends on: 1576047
No longer depends on: 1575689
Whiteboard: [passwords:management] [skyline] [depends on bug 1575689] → [passwords:management] [skyline]
Whiteboard: [passwords:management] [skyline] → [passwords:management] [skyline][access-p1]

Now that bug 1576047 has landed, can you please test this again?

Flags: needinfo?(ciprian.georgiu)

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #6)

Now that bug 1576047 has landed, can you please test this again?

Unfortunately, it is still reproducible on latest Nightly 71, the breach warning and the "X" button doesn't show up.

Flags: needinfo?(ciprian.georgiu)
Attached image breach-indicator.png

The breach indicator in the logins list is now visible but barely and certainly not visible enough being a dark red on a black background. The close x button on the breach notification banner is still completely invisible.

[Tracking Requested - why for this release]:

The accessibility team considers this a P1 defect because it substantially breaks the breach notification feature for low vision users.

Tracking for 70 release, hoping we can get a fix in for beta 11 or 12 next week.

Flags: needinfo?(MattN+bmo)
Flags: needinfo?(MattN+bmo) → needinfo?(jaws)
Flags: needinfo?(MattN+bmo)

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f0a61485099
Show breach notification icons in high contrast mode. r=MattN
https://hg.mozilla.org/integration/autoland/rev/faaf976800c2
Show the close icon in the confirmation-dialog in high contrast mode. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Flags: qe-verify+

I have verified this issue on the Firefox Beta 70.0b13 (Build ID: 20191007220302) and on the latest Nightly 71.0a1 (Build ID: 20191008214557) build on Windows 10 x64.

  • The breach warning icon and the “x” button are correctly displayed in High Contrast Mode.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.