Closed Bug 1575303 Opened 4 months ago Closed 2 months ago

Weird text on phabricator after small scroll

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: jesup, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image WR2.png

See the image - text went weird/missing after a small scroll. Scrolling didn't fix it. Switching tabs and switching back caused the error to disappear.

69.0b11 Windows10 NVidia GTX 950 driver 23.21.13.8813
WebRender

:jesup, can the problem could be reproduced with latest beta and latest nightly?

Flags: needinfo?(rjesup)

I can't get it to reproduce even in the same running instance. Once I switched tabs and came back the problem was gone

Flags: needinfo?(rjesup)
Blocks: wr-69

Hmm, we do not have a concrete STR to reproduce the problem :(

:lsalzman, do you know if there was a similar bug?

Flags: needinfo?(lsalzman)
Priority: -- → P3
Blocks: wr-70
No longer blocks: wr-69

Not entirely sure what is going on here. It looks like the glyph/texture cache got out of sync somehow, with the glyph cache pointing into junk/something else in the texture. This should theoretically never happen based on our existing safeguards to ensure that a glyph is in the texture cache when we request/resolve it...

Flags: needinfo?(lsalzman)

Randell, have you seen this again?

Flags: needinfo?(rjesup)

I haven't... but I don't use phab a lot

Flags: needinfo?(rjesup)

Marking as FIXED. If you see it again please reopen?

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.