Closed Bug 1575359 Opened 3 months ago Closed 3 months ago

Change string on the button on the Lockwise Card

Categories

(Firefox :: Protections UI, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: betsymi, Assigned: ewright)

References

(Blocks 1 open bug)

Details

(Whiteboard: [protection-report][skyline])

Attachments

(1 file)

Current string says Open in Nightly, Open in Firefox, etc. Update to: View Logins

Reason for this change: The action should be focusing on where the user is going and what they will do when they get there, rather than what is technically happening when they select the button.

Summary: Change string on Lockwise Card Button → Change string on the button on the Lockwise Card
No longer depends on: 1574161
Type: defect → task
Blocks: 1577459
Blocks: 1577462
Blocks: 1577465
Priority: P3 → P1
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0d7d7218f37
Update string on the Lockwise card button. r=fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 70 → ---
Flags: needinfo?(ewright)

(In reply to Andreea Pavel [:apavel] from comment #4)

Backed out on request from Erica

Erica, can you give more background on the request? The reason I'm asking is that this change was already exposed for localization. If the string is going to re-land as is, I'd prefer to avoid losing existing translations (there are 17 already).

No idea why this was backed out (and I can't find any public conversations). Unless Andrea can point us towards something this will probably just have to go into 71, since Erica is on public holiday today.

Flags: needinfo?(apavel)

(Which is probably fine)

Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a62d5742e64
Update string on the Lockwise card button. r=fluent-reviewers,flod CLOSED TREE

(In reply to Johann Hofmann [:johannh] from comment #9)

🤔

Fill in the blanks: Erica pinged me on Slack earlier saying the back-out was a misunderstanding, I asked sheriffs on IRC to re-land (not sure we'll also get Beta at this point).

Comment on attachment 9089200 [details]
Bug 1575359 - Update string on the Lockwise card button.

Beta/Release Uplift Approval Request

  • User impact if declined: Obsolete string in about:protections
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only changing a button label. The original patch landed before merge, but was backed out by mistake.
  • String changes made/needed: Yes
Attachment #9089200 - Flags: approval-mozilla-beta?
Flags: needinfo?(ewright)
Flags: needinfo?(apavel)

I see! Thanks for taking care of that.

Comment on attachment 9089200 [details]
Bug 1575359 - Update string on the Lockwise card button.

string update for 70.0b3

Attachment #9089200 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

(In reply to Johann Hofmann [:johannh] from comment #6)

No idea why this was backed out (and I can't find any public conversations). Unless Andrea can point us towards something this will probably just have to go into 71, since Erica is on public holiday today.

Hi, Erica left me an offline message on Slack about backing this out and i did so the next day. After she mentioned that it seemed that the backout was not needed as there were no issues with the patch so she'd ask for a relanding.

Johann I also pinged you on IRC before making the backout but seems like you were away

You need to log in before you can comment on or make changes to this bug.