Closed Bug 1575451 Opened 1 year ago Closed 5 months ago

Text selection Blue marker scrolls with the page

Categories

(Core :: Layout, defect)

68 Branch
Unspecified
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1526268
Webcompat Priority ?
Tracking Status
firefox70 --- affected

People

(Reporter: karlcow, Unassigned)

References

(Blocks 1 open bug, )

Details

initially on https://webcompat.com/issues/32939

When you open the editable text area to write a message as you usual you have a blue marker near the cursor position. But if you scroll the main page with the editable text area active the blue marker scrolls with the page instead of staying near the cursor.
This bug is present on firefox mobile 67.0, firefox nigthly mobile 68.0a1 and firefox preview 1.0.1921. This issue is not present on chrome mobile

Component: Text Selection → General
Product: Firefox for Android → GeckoView
Version: Firefox 68 → 68 Branch

Ting-Yu, does this look like a Layout bug? Is the Gecko Layout code responsible for positioning the blue text selection markers?

GIF animation of the bug:
https://user-images.githubusercontent.com/17617810/59436962-eaa72200-8df0-11e9-98c0-a0925b327192.gif

Component: General → Layout
Flags: needinfo?(aethanyc)
Product: GeckoView → Core

(In reply to Chris Peterson [:cpeterson] from comment #1)

Ting-Yu, does this look like a Layout bug? Is the Gecko Layout code responsible for positioning the blue text selection markers?

Yes, AccessibleCaret is responsible for positioning the blue carets. The discourse reply field is a "position: fixed" element, so this is a dup of bug 1526268.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(aethanyc)
Resolution: --- → DUPLICATE
Duplicate of bug: 1526268
You need to log in before you can comment on or make changes to this bug.