Failure to instantiate plugin in nsPluginStreamListenerPeer::OnStartRequest does not cause us to layout alternate renderings

RESOLVED FIXED in mozilla17

Status

()

Core
Plug-ins
P2
normal
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Peter Lubczynski, Assigned: johns)

Tracking

Trunk
mozilla17
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:P2])

(Reporter)

Description

15 years ago
Sometimes plugin code needs to open the stream of an OBJECT (or EMBED) tag in
order to find out the mime-type to use. We do not handle failure here gracefully.

For example:

<object data="missing.file" width=100 height=100>
  Alternate Rendering
</object>

This fails becuase layout never gets a call to CantRenderReplaceElement in
OnStartRequest.

Another similar case that fails is when we are only able to determine the
mime-type from the HTTP header and it's not a handled by a plugin, we never give
layout a chance to see if it can handle it. 

For example:
<object data="http://www.mozilla.org/ width=100 height=100></object>

This fails because a new child nsFrameFrame or nsImageFrame are not created in
OnStartRequest.

I'm investigating on ways to fix this. Calling back into layout for replacement
probably isn't a problem. However, we need to ensure we do not make two requests
when trafering control to the IFRAME or IMG tag code.
(Reporter)

Updated

15 years ago
Blocks: 96579
(Reporter)

Comment 1

15 years ago
Since this is sort of serious and I have sort of an idea of how to fix it now,
lets try to get this done in the near-term....of course if plugins move to
content in bug 90268, this bug would be a good learning experience :)
Priority: -- → P2
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.2beta

Updated

15 years ago
Severity: major → normal
Target Milestone: mozilla1.2beta → mozilla1.0.2

Updated

15 years ago
Blocks: 96976
(Reporter)

Comment 2

15 years ago
*** Bug 156199 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
*** Bug 157150 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Whiteboard: [PL2:NA] → [PL2:P2]
Target Milestone: mozilla1.0.2 → mozilla1.2alpha

Updated

15 years ago
Blocks: 108946
(Reporter)

Updated

15 years ago
Blocks: 109082
(Reporter)

Updated

15 years ago
Target Milestone: mozilla1.2alpha → mozilla1.3alpha

Comment 4

15 years ago
1.3 beta
Target Milestone: mozilla1.3alpha → mozilla1.3beta
(Reporter)

Updated

15 years ago
Blocks: 185412
(Reporter)

Updated

15 years ago
No longer blocks: 185412
(Reporter)

Comment 5

15 years ago
*** Bug 175465 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

15 years ago
Blocks: 195030

Updated

14 years ago
Blocks: 230471
Depends on: 1156
QA Contact: shrir → plugins
(Assignee)

Updated

5 years ago
No longer blocks: 96976
(Assignee)

Comment 6

5 years ago
bug 745030 should either fix this or make it a much simpler fix
Assignee: peterl-bugs → jschoenick
Status: NEW → ASSIGNED
Depends on: 745030
Target Milestone: mozilla1.3beta → ---
(Assignee)

Updated

5 years ago
No longer blocks: 195030
(Assignee)

Comment 7

5 years ago
This was fully fixed by 745030, although most cases of it had been fixed previously.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
Target Milestone: --- → mozilla17
(Assignee)

Updated

5 years ago
Resolution: INCOMPLETE → FIXED
You need to log in before you can comment on or make changes to this bug.