Closed Bug 1575805 Opened 9 months ago Closed 9 months ago

Manually expanded section will be collapsed again after visiting a bug that hides the section by default

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: standard8, Assigned: kohei)

References

Details

Attachments

(1 file)

STR:

  1. Search for various bugs to go through them, e.g. for triage.
  2. Open up a bug in a new tab, see the "References" section is collapsed.
  3. Click the "References" header to expand it.
  4. Close the tab, or go back to the list.
  5. Open another bug which doesn't have any references.
  6. Go back to the list, and open a bug which now does have references.

Expected Results: The references section should be expanded.

Actual Results: The references section is collapsed.

I suspect this was regressed by bug 1344091.

Thanks, I’ll take a look once I get back to work.

Assignee: nobody → kohei.yoshino

As per IRC, the Crash Data section may have the same issue. For example, the crash table in Bug 1575023 is hidden until you reload the page.

I believe this is not a regression because I haven’t touched the accordion functionality in Bug 1344091, but now with the References section that can be hidden by default, people may encounter the issue more often.

No longer regressed by: 1344091
See Also: → 1344091
Summary: References section keeps on being closed when I view bugs → Manually-expanded section will be collapsed after visiting a bug that hides the section
Summary: Manually-expanded section will be collapsed after visiting a bug that hides the section → Manually expanded section will be collapsed again after visiting a bug that hides the section by default
Duplicate of this bug: 1576834
Status: NEW → ASSIGNED
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.