Closed Bug 1575846 Opened 2 years ago Closed 1 year ago

Crash in [@ mozilla::MP3TrackDemuxer::GetBuffered]

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- unaffected
firefox70 --- fix-optional

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-4c72cc58-fbe3-4474-a137-f4a5b0190821.

Seen while looking at nightly crash stats. Similar crash in Bug 1535603 but it was fixed by backout: https://mzl.la/31UVIyk. Crashes started in 20190820093833

Possible regression range based on build id: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fd450d47a9f764098c887cfa8cdf9c390d0e3063&tochange=0dc91d87721bbd95ec2bccd1bfff87f22125ae6d

One URL: https://web.whatsapp.com/

Top 10 frames of crashing thread:

0 xul.dll class mozilla::media::TimeIntervals mozilla::MP3TrackDemuxer::GetBuffered dom/media/mp3/MP3Demuxer.cpp
1 xul.dll void mozilla::MediaFormatReader::DemuxerProxy::Wrapper::UpdateBuffered dom/media/MediaFormatReader.cpp:707
2 xul.dll nsresult mozilla::detail::ProxyFunctionRunnable<`lambda at z:/task_1566296118/build/src/dom/media/MediaFormatReader.cpp:780:44', mozilla::MozPromise<bool, mozilla::MediaResult, 1> >::Run xpcom/threads/MozPromise.h:1440
3 xul.dll nsresult mozilla::TaskQueue::Runner::Run xpcom/threads/TaskQueue.cpp:199
4 xul.dll nsresult nsThreadPool::Run xpcom/threads/nsThreadPool.cpp:246
5 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225
6 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
7 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:303
8 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
9 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:290

Priority: -- → P2

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.