Closed Bug 1576020 Opened 5 years ago Closed 3 years ago

a YouTube HDR video plays in SDR instead

Categories

(Core :: Audio/Video: Playback, defect, P3)

69 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1539685
Tracking Status
firefox75 --- affected
firefox76 --- affected
firefox77 --- affected

People

(Reporter: pgoldberg, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I played a YouTube HDR video and although it was stated it was in HDR VP9.02 it played very dull as if it was in SDR. The same video played in Chrome was vibrant and much brighter as HDR should be. I am using an ATI RX580 video card with the latest drivers. My OS is Windows 10 ver. 1903. Firefox 69b13. I have a LG 32GK850F-B 32 Inch UltraGear™ QHD Gaming Monitor with Radeon FreeSync™ 2 Technology which has HDR and Windows in in the HDR mode.
https://www.youtube.com/watch?v=mkggXE5e2yk

Actual results:

The HDR YouTube video did not appear to be in HDR but appeared to be SDR.

Expected results:

The YouTube video should be much brighter as it appears in Chrome.

Correction I am using Firefox 60b15.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Summary: YouTube HDR → a YouTube HDR video plays in SDR instead
Attached image Screenshot (14).png

From YouTube on the left is from Chrome and on the right is from Firefox 69b16.

Attached image Screenshot (15).png

In Windows 10 version 1903 you can in Display Settings toggle HDR on or off. This picture is with HDR off. You can see in Chrome the colors are less intense. But in Firefox it is still much less colorful than Chrome and it appears almost the same as the HDR version in Firefox. So something is causing Firefox not to display the colors and brightness correctly.
WEBRENDER
opt-in by default: WebRender is an opt-in feature
available by user: Qualified in release.

One additional thing I noticed when I disable HDR on my computer Firefox still shows the HDR indicator on the video but Chrome does not it just shows HD. On my laptop which has an old video card and cannot display HDR content I get the same results with HDR displayed in Firefox. The picture quality of the colors looks almost identical to the picture I submitted of my desktop in the SDR mode. (On my laptop WebRender is disabled because of the age of the video card.)

Paul, thank you for the detailed report. We have an open bug (Bug 1539685) to track adding HDR support to Firefox. For now, I'll add this bug as a blocking bug there.

@Jean-Yves, feel free to mark as duplicate or re-prioritize if needed.

Status: UNCONFIRMED → NEW
Depends on: HDR
Ever confirmed: true
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE

Per bug1580695 comment8, it's not a dupilicate of bug1580695.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Just adding that I have this same issue on a laptop with a built-in HDR screen(Dell XPS 13 2in1 7390). HDR displays correctly in Chrome and Edge.

Hi, same issue!

Please fix this

using Firefox 69.0.03

¡Hola!

Ended up here while researching an answer for https://support.mozilla.org/es/questions/1284184/

Updating flags FWIW.

¡Gracias!
Alex

Blocks: 1642854

Is there something new about this topic?
I like firefox, but I need HDR-support for my work. Please add this feature.
(P.S.: I love it, that media control is available since few months. Nice work!)

Hi, Jya, I wonder if you would have any idea about that? I don't know what the status is for our HDR support, Is that something we haven't supported yet?
Thank you.

Flags: needinfo?(jya-moz)

We have no HDR support other than converting 10 bits YUV into 8 bits RGB. We don't do any tone mapping either like chrome or VLC would be doing when playing HDR on a SDR screen

Additionally, YouTube no longer serves us any HDR content.

This bug should be closed or make a duplicate of whatever bug is to be used to properly implement HDR support.

Flags: needinfo?(jya-moz)

Thank you. If I understand that correctly, we're still in a planning stage for HDR content, so I'm going to make this duplicate to the meta bug of HDR.

Status: REOPENED → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.