Closed Bug 1576030 Opened 4 months ago Closed 4 months ago

Disable cargo incremental when using sccache

Categories

(Firefox Build System :: General, task)

task
Not set

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.

For some reason, cargo incremental doesn't work as well as it should,
and doesn't perform as well as sccache does. So when building with
sccache, disable cargo incremental. This brought a no-change clobber
build with 100% cache from 3:50 to 2:05 on a beefy AWS instance I was
testing this with.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/e21bc14e05be
Disable cargo incremental when using sccache. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/cace4ffbecb2
Allow to forcefully enable cargo incremental. r=nalexander

I got the second part backed out because js_options that have varying behavior but not through its default make the default the value used in js... so here that means automation started enabling cargo incremental in js/. Not great. I'll file a followup to handle the "Allow to forcefully enable cargo incremental" part.

Flags: needinfo?(mh+mozilla)
Blocks: 1576099
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1551314
You need to log in before you can comment on or make changes to this bug.