Linux games is able to popup an ad even though preferences are set not to allow that

VERIFIED DUPLICATE of bug 126224

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 126224
16 years ago
13 years ago

People

(Reporter: Mark Purtill, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In Preferences/Advanced/Scripts & Windows, I have both "Open unrequested
windows" and "Open a link in a new window" unchecked.  However,
http://www.linuxgames.com/ is still able to pop up an ad.

This is with Mozilla 1.0 ("Build Id: 00000000000").

Comment 1

16 years ago
WFM, trunk build 2002071504 - WinXP.

Did you trunk with a pre-built build ? ;-)
(Reporter)

Comment 2

16 years ago
I'm not sure exactly what you're asking, but I do get the same behavior with
1.1alpha (build 2002061108) and the latest nightly build (2002071608).

Comment 3

16 years ago
This works for me as well... 

Reporter, does the popup occur onload? or do you have to perform some action to
get it to appear?

Could you please provide exact steps to reproduce. (Or perhaps find the
offending code in the web page that is opening the window.)
(Reporter)

Comment 4

16 years ago
Created attachment 93378 [details]
Files needed to reproduce the bug (for me)

I think it may depend on which ad is up on the web site whether you get the
popup.	This attachment is a cutdown version that seems to reproduce the
problem for me.

Comment 5

16 years ago
*** Bug 160527 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Confirming based on report from duplicate bug. 

Mark: what format is your attachment in Comment #4? I tried 
WinZip on it, and tar -zxf on it, and neither one worked -
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

16 years ago
Sorry, I should have said.  It's a bzip2ed tar file, so tar -xjf if you've got a
recent tar.

Comment 8

16 years ago
> I think it may depend on which ad is up on the web site whether you
> get the popup. This attachment is a cutdown version that seems to
> reproduce the problem for me.

Mark: great work to isolate the problem for us. I was able to 
successfully tar -xjf the bzip2ed tar file in Comment #4. 

Once I had it, I was able to open mozilla-bug-157629.html and
step through it line-by-line in Mozilla's JavaScript Debugger

   ( Tools > Web Development > JavaScript Debugger)


The parent file loads some frames, and one of them is 
TypeclickFlightID.html, which contains this code:


function popunder()
{
  var pop = window.open("","pop",props); <<<-------------- OPENS THE NEW WINDOW
  pop.blur();
  pop.document.open();
  pop.document.write('<html><head><title></title>');
  pop.document.write('<scr'+'ipt language="javascript">');
  pop.document.write('var clickthru="http://ad.doubleclick.net/ etc. etc.

               etc.
               etc.
}


and the HTML contains a call to this function as follows:


<img src="TypeclickFlightID_data/817-gray.gif"
     border="0" width="1" height="1"
     onload="popunder();return false;">  <<<------------- IT GETS CALLED HERE



That is the new trick site authors are using to circumvent our
popup blocking: they are putting the popups in <img onload>.

A fix for this is explained in bug 126224, "NY Times web sites create
pop-up windows even if that feature is disabled (by using img onload)"

So I'm going to dupe this bug against that one. You will be 
automatically cc'ed on it so you can follow what happens.

Note that bug has a very long and complicated history. A new,
"behind-the-scenes" pref was created that you have to add
manually in your pref file ("user.js", "all.js", or "prefs.js").

It looks something like this:

       user_pref("dom.disable_open_click_delay", 1000);

A full explanation is given in bug 126224.


Thank you for such thorough reporting on this bug -

*** This bug has been marked as a duplicate of 126224 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.