Closed Bug 1576775 Opened 2 months ago Closed 2 months ago

Compose window launched by mailto doesn't receive focus, it's behind the Firefox window

Categories

(External Software Affecting Firefox :: Other, defect)

defect
Not set

Tracking

(firefox68 affected)

RESOLVED DUPLICATE of bug 1570845
Tracking Status
firefox68 --- affected

People

(Reporter: jscher2000, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Clicked a mailto link such as

mailto:bob@example.com

In the Launch Application dialog, I selected Outlook (default application for mailto in Windows).

Actual results:

Compose window opened but did not receive focus. The Outlook button on the Windows Taskbar flashed to get my attention.

With subsequent uses of mailto links, the compose window opened in front.

(Similar pattern with Firefox Developer Edition: first use of mailto, the compose window did not get focus. Subsequent uses worked normally.)

Two users on SUMO reported that the compose window never gets focus on their system, on the first or on subsequent uses of mailto links:

Expected results:

The compose window should always open in front of the Firefox window and have focus.

This appears to have begun with 68.0.2, potentially regressed by bug 1567614

I can't reproduce this behavior on Nightly. However, it is oddly slow at bringing the first compose window to the front.

Seems dupulication of Bug 1570845

Component: Untriaged → Other
Product: Firefox → External Software Affecting Firefox
Version: 68 Branch → unspecified
Keywords: regression
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1570845
You need to log in before you can comment on or make changes to this bug.