Closed Bug 1576832 Opened 4 months ago Closed 4 months ago

Intermittent [TV] browser/base/content/test/siteProtections/browser_protections_UI.js | The tracking protection icon state has been changed to disabled. -

Categories

(Firefox :: Protections UI, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: timhuang)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: aiakab [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263643952&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/POqIxdRMTvqHrKOhHVTq1A/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/POqIxdRMTvqHrKOhHVTq1A/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-08-27T06:26:49.502Z] 06:26:49 INFO - Leaving test bound testNumberOfBlockedTrackers
[task 2019-08-27T06:26:49.502Z] 06:26:49 INFO - Entering test bound testSubViewTelemetry
[task 2019-08-27T06:26:49.503Z] 06:26:49 INFO - Buffered messages logged at 06:26:37
[task 2019-08-27T06:26:49.506Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded trackers telemetry event -
[task 2019-08-27T06:26:49.507Z] 06:26:49 INFO - Buffered messages logged at 06:26:38
[task 2019-08-27T06:26:49.508Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded subview_settings telemetry event -
[task 2019-08-27T06:26:49.508Z] 06:26:49 INFO - Buffered messages logged at 06:26:39
[task 2019-08-27T06:26:49.509Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded social telemetry event -
[task 2019-08-27T06:26:49.509Z] 06:26:49 INFO - Buffered messages logged at 06:26:40
[task 2019-08-27T06:26:49.509Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded subview_settings telemetry event -
[task 2019-08-27T06:26:49.510Z] 06:26:49 INFO - Buffered messages logged at 06:26:41
[task 2019-08-27T06:26:49.513Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded cookies telemetry event -
[task 2019-08-27T06:26:49.520Z] 06:26:49 INFO - Buffered messages logged at 06:26:43
[task 2019-08-27T06:26:49.520Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded subview_settings telemetry event -
[task 2019-08-27T06:26:49.521Z] 06:26:49 INFO - Buffered messages logged at 06:26:44
[task 2019-08-27T06:26:49.521Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded cryptominers telemetry event -
[task 2019-08-27T06:26:49.524Z] 06:26:49 INFO - Buffered messages logged at 06:26:45
[task 2019-08-27T06:26:49.524Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded subview_settings telemetry event -
[task 2019-08-27T06:26:49.525Z] 06:26:49 INFO - Buffered messages logged at 06:26:46
[task 2019-08-27T06:26:49.528Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded fingerprinters telemetry event -
[task 2019-08-27T06:26:49.531Z] 06:26:49 INFO - Buffered messages logged at 06:26:47
[task 2019-08-27T06:26:49.532Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded subview_settings telemetry event -
[task 2019-08-27T06:26:49.532Z] 06:26:49 INFO - Leaving test bound testSubViewTelemetry
[task 2019-08-27T06:26:49.532Z] 06:26:49 INFO - Entering test bound testQuickSwitchTabAfterTogglingTPSwitch
[task 2019-08-27T06:26:49.533Z] 06:26:49 INFO - Buffered messages logged at 06:26:48
[task 2019-08-27T06:26:49.533Z] 06:26:49 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | The tracking protection icon state is still enabled. -
[task 2019-08-27T06:26:49.534Z] 06:26:49 INFO - Buffered messages finished
[task 2019-08-27T06:26:49.534Z] 06:26:49 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteProtections/browser_protections_UI.js | The tracking protection icon state has been changed to disabled. -
[task 2019-08-27T06:26:49.534Z] 06:26:49 INFO - Stack trace:
[task 2019-08-27T06:26:49.535Z] 06:26:49 INFO - chrome://mochikit/content/browser-test.js:test_ok:1580
[task 2019-08-27T06:26:49.535Z] 06:26:49 INFO - chrome://mochitests/content/browser/browser/base/content/test/siteProtections/browser_protections_UI.js:testQuickSwitchTabAfterTogglingTPSwitch:614
[task 2019-08-27T06:26:49.536Z] 06:26:49 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-08-27T06:26:49.536Z] 06:26:49 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-08-27T06:26:49.536Z] 06:26:49 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1207
[task 2019-08-27T06:26:49.537Z] 06:26:49 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805
[task 2019-08-27T06:26:49.537Z] 06:26:49 INFO - Leaving test bound testQuickSwitchTabAfterTogglingTPSwitch
[task 2019-08-27T06:26:49.538Z] 06:26:49 INFO - GECKO(1085) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-08-27T06:26:49.538Z] 06:26:49 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-08-27T06:26:49.539Z] 06:26:49 INFO - GECKO(1085) | MEMORY STAT | vsize 3092MB | residentFast 489MB | heapAllocated 204MB
[task 2019-08-27T06:26:49.539Z] 06:26:49 INFO - TEST-OK | browser/base/content/test/siteProtections/browser_protections_UI.js | took 22860ms

The failure is a bit misleading, because the assertion's [1] info message is wrong (I think it was copied over from another one and wasn't updated properly, and I missed it in review). I believe the issue is that we assume that selectedBrowser gives us the correct browser reference after we set selectedTab. But the issue is that setting selectedTab only sets the tab, and gBrowser.selectedBrowser is updated via an event callback [2] after a select event on the tabpanels element. This means it's async and therefore we cannot rely on it to work immediately after setting selectedTab. One solution is to simply pass tabTwo.linkedBrowser to ContentBlockingAllowList.includes() - I prefer this. The other solution is to spin the event loop before accessing selectedBrowser.

Tim, want to take this follow-up? We should also update the assertion's info message while we're here. Thanks!

I took the liberty of changing the regressed-by field to bug 1575788.

[1] https://searchfox.org/mozilla-central/rev/325c1a707819602feff736f129cb36055ba6d94f/browser/base/content/test/siteProtections/browser_protections_UI.js#613
[2] https://searchfox.org/mozilla-central/rev/325c1a707819602feff736f129cb36055ba6d94f/browser/base/content/tabbrowser.js#5107

Flags: needinfo?(nhnt11) → needinfo?(tihuang)
Regressed by: 1575788
No longer regressed by: 1575246
Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Flags: needinfo?(tihuang)
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2187d722dc38
Fix the info and check of the ETP state to use the right browser object for the test 'browser_protections_UI.js' r=nhnt11
Regressions: 1576871
Component: General → Tracking Protection
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.